summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/distrobox')
-rw-r--r--app-containers/distrobox/Manifest3
-rw-r--r--app-containers/distrobox/distrobox-1.7.1.ebuild35
-rw-r--r--app-containers/distrobox/distrobox-1.7.2.0.ebuild35
-rw-r--r--app-containers/distrobox/distrobox-1.7.2.1.ebuild35
-rw-r--r--app-containers/distrobox/distrobox-9999.ebuild35
-rw-r--r--app-containers/distrobox/metadata.xml22
6 files changed, 165 insertions, 0 deletions
diff --git a/app-containers/distrobox/Manifest b/app-containers/distrobox/Manifest
new file mode 100644
index 000000000000..35a9897fa802
--- /dev/null
+++ b/app-containers/distrobox/Manifest
@@ -0,0 +1,3 @@
+DIST distrobox-1.7.1.tar.gz 6885484 BLAKE2B c4b2710d7f1cff7baee2e340a79345359e9906e508e8b1bc351a7b8ee2d8d2e1cb13c381e40231f8c962542e37e32988d04a687810bdfd7ec917868944c51cf3 SHA512 a86a49b9f6158af3172369a201ce3852a349258c46ebb8dfb269f7b96dfbe2bf2fe9f80a5cf9b9236432d99f4f67fb3d95ab4663964fcdb0f888d48cbdd82c39
+DIST distrobox-1.7.2.0.tar.gz 6888905 BLAKE2B f74301464f3b590f246871be1a381771e0fccbd42a933b9d2a58874eb97e49ae73676f7267b56dc7facefdba6cac1fc3df52d55ef826c0d79c90bbe9e0955af7 SHA512 ae5c9ef7ee63beec6b99488091cdb5bc73dfb219988a71c624af2278ea2efc775895ae2106c6bc35783a317b5b3e92fceed2fdba5be05f94028d28a7a2fb8ce1
+DIST distrobox-1.7.2.1.tar.gz 6888919 BLAKE2B 1fd4e49585f686cf9f434c3285935bdda1131684b74dfcc20b018ab9853fb13516f3dbaf7c16b9ea55a0d038e3d9eb297bcea74c95755fbe60ef6512a9ce0df8 SHA512 aaf4324a9a31844dc08a6cc4e06d3b725675c92df01b558e733c96701d7e9700baabc1afad97ce5e2a8e2345defcea71c85f0ea6667249316f850aeca5aea149
diff --git a/app-containers/distrobox/distrobox-1.7.1.ebuild b/app-containers/distrobox/distrobox-1.7.1.ebuild
new file mode 100644
index 000000000000..a49244c1584d
--- /dev/null
+++ b/app-containers/distrobox/distrobox-1.7.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Use any Linux distribution inside your terminal (powered by docker/podman)"
+HOMEPAGE="https://distrobox.privatedns.org/
+ https://github.com/89luca89/distrobox/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/89luca89/${PN}.git"
+else
+ SRC_URI="https://github.com/89luca89/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-3" # GPL-3.0-only !
+SLOT="0"
+
+RDEPEND="
+ || (
+ app-containers/docker
+ app-containers/podman
+ )
+"
+
+src_install() {
+ sh ./install --prefix "${ED}/usr" || die "${PN} install script failed"
+
+ dodoc *.md
+}
diff --git a/app-containers/distrobox/distrobox-1.7.2.0.ebuild b/app-containers/distrobox/distrobox-1.7.2.0.ebuild
new file mode 100644
index 000000000000..0a328c47011d
--- /dev/null
+++ b/app-containers/distrobox/distrobox-1.7.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Use any Linux distribution inside your terminal (powered by docker/podman)"
+HOMEPAGE="https://distrobox.it/
+ https://github.com/89luca89/distrobox/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/89luca89/${PN}.git"
+else
+ SRC_URI="https://github.com/89luca89/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-3" # GPL-3.0-only !
+SLOT="0"
+
+RDEPEND="
+ || (
+ app-containers/docker
+ app-containers/podman
+ )
+"
+
+src_install() {
+ sh ./install --prefix "${ED}/usr" || die "${PN} install script failed"
+
+ dodoc *.md
+}
diff --git a/app-containers/distrobox/distrobox-1.7.2.1.ebuild b/app-containers/distrobox/distrobox-1.7.2.1.ebuild
new file mode 100644
index 000000000000..0a328c47011d
--- /dev/null
+++ b/app-containers/distrobox/distrobox-1.7.2.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Use any Linux distribution inside your terminal (powered by docker/podman)"
+HOMEPAGE="https://distrobox.it/
+ https://github.com/89luca89/distrobox/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/89luca89/${PN}.git"
+else
+ SRC_URI="https://github.com/89luca89/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-3" # GPL-3.0-only !
+SLOT="0"
+
+RDEPEND="
+ || (
+ app-containers/docker
+ app-containers/podman
+ )
+"
+
+src_install() {
+ sh ./install --prefix "${ED}/usr" || die "${PN} install script failed"
+
+ dodoc *.md
+}
diff --git a/app-containers/distrobox/distrobox-9999.ebuild b/app-containers/distrobox/distrobox-9999.ebuild
new file mode 100644
index 000000000000..ddd8a782dfb3
--- /dev/null
+++ b/app-containers/distrobox/distrobox-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Use any Linux distribution inside your terminal (powered by docker/podman)"
+HOMEPAGE="https://distrobox.privatedns.org/
+ https://github.com/89luca89/distrobox/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/89luca89/${PN}.git"
+else
+ SRC_URI="https://github.com/89luca89/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-3" # GPL-3.0-only !
+SLOT="0"
+
+RDEPEND="
+ || (
+ app-containers/docker
+ app-containers/podman
+ )
+"
+
+src_install() {
+ sh ./install --prefix "${ED}/usr" || die "${PN} install script failed"
+
+ dodoc *.md
+}
diff --git a/app-containers/distrobox/metadata.xml b/app-containers/distrobox/metadata.xml
new file mode 100644
index 000000000000..b88c63cda978
--- /dev/null
+++ b/app-containers/distrobox/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ Use any Linux distribution inside your terminal. Enable both backward and
+ forward compatibility with software and freedom to use whatever
+ distribution you’re more comfortable with. Distrobox uses podman or docker
+ to create containers using the Linux distribution of your choice. The
+ created container will be tightly integrated with the host, allowing
+ sharing of the HOME directory of the user, external storage, external USB
+ devices and graphical apps (X11/Wayland), and audio.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/89luca89/distrobox/issues/</bugs-to>
+ <remote-id type="github">89luca89/distrobox</remote-id>
+ </upstream>
+</pkgmetadata>