summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/grype')
-rw-r--r--app-containers/grype/Manifest8
-rw-r--r--app-containers/grype/grype-0.59.1.ebuild33
-rw-r--r--app-containers/grype/grype-0.61.0.ebuild33
-rw-r--r--app-containers/grype/grype-0.72.0.ebuild34
-rw-r--r--app-containers/grype/grype-0.73.0.ebuild34
-rw-r--r--app-containers/grype/metadata.xml8
6 files changed, 150 insertions, 0 deletions
diff --git a/app-containers/grype/Manifest b/app-containers/grype/Manifest
new file mode 100644
index 000000000000..eeb89d8c7035
--- /dev/null
+++ b/app-containers/grype/Manifest
@@ -0,0 +1,8 @@
+DIST grype-0.59.1-deps.tar.xz 555292828 BLAKE2B ce132ecd42efd2c76bce1843b1da2ff763494a0206c8618c95ec03ae9d73a77378a68e503de9115c73efd6acbab4cc30bf222676c7888aafb08de8454351fb2b SHA512 aa627bfbf52c218786d009dee6e37bc09d70fd98ad10b8c07ec91db9d15380a1fbc35f380ee22fae8b6e7b090d1aabfebf58bc1ea6bca2bd179dcaa74b52a2c0
+DIST grype-0.59.1.tar.gz 1021093 BLAKE2B 0c5b0a8a14e297e123965d451daff082cbabb01f766ec355a37d54d7044b865430aa7cbec20d8002feac33f93e24565ebe6346a8559e8a25bf3df1dcc8ca217e SHA512 8f219ade9d7369f124dd8c035f3bef6ce5055e318d7ab1578f7f98a7fa6e842dad26fae8b2337884d4af3773b2c590b61485a490f98c66dfcbd82ef73d8b766b
+DIST grype-0.61.0-deps.tar.xz 562038080 BLAKE2B cb780751f50f9c74ac9f9a7064e489211bdfbd3d9df5fbd3fd51aa6081a48cac38b5efcaf524708cb010b3767c7bf31eaf8151e96f610ae84a814de767beec8e SHA512 eca6b813c140af26533154ca10f50a44351bef921e6140c3ae02c8b888d4e43bd7163954684463c19acf3c11b7ee93c1531b4b1042f0cd3886e1da36f384c029
+DIST grype-0.61.0.tar.gz 1021705 BLAKE2B 32ff98f3f240ee5d883edb568ff9caa7614053e76ea9bd8a774a5abb92091e4356e25c10b94d9aaf4a17a2f8c4c7d0f26e2ceec8a089ca079029893d255a7480 SHA512 ce4b1805f17bccd3281a218673156669ae632418bdfabf95c310b973bc224b89b7e0e3ca57a8c7e1df444074e034092d963df3b11cbf393e500fe1786f707ed5
+DIST grype-0.72.0-deps.tar.xz 599210536 BLAKE2B 4912cf4278488e78c7a174654da20f640c4975b5e98741e7caa94d9865ae51013a410863ee68c520805985afc19ca0b2b2175b8f2241724ceac86217719efd82 SHA512 1a91f1b46dc5a206025554c32f5420019ff0f8de564b67ad91070bdbe46abb71f08d409856799672cc31a7d753e151343d925147332caeb044f3cfd81318ff08
+DIST grype-0.72.0.tar.gz 1114440 BLAKE2B 931f4bdd883471e8b34b09dd1df53d4e67df96fc0d7be5224d1acfecc618cb068ee268f4b269e5a7f5e01a6605b9e01f8bb6a150819e8410a6b4f0daa12877ff SHA512 8335de5cba0b11500df1404afeee311be50c7e55d1a57c85cbebe830c9e8d9d21ff7b35ab6110200e57f464e999576f395814a56485115f8c7ed7b6e9f7dafb9
+DIST grype-0.73.0-deps.tar.xz 627765660 BLAKE2B 3d3949922a635d0654120aaf05edef38e7ae998c7beab89a7f13de994ab5f34bd6ade6a67145f5a366a2956ffb124a94a952b426a71cb50a7a30f65a7d721784 SHA512 f2e0ba2da0c196e705a23efc9e989ed3525d3465d661a2d5ce832c0663b0226a885541d91a773922f32de4d849030b73c307487eec00d0498368925213b9444d
+DIST grype-0.73.0.tar.gz 1124082 BLAKE2B 835b1833e6809510821f07906df06c55b418f7226dba190b4bf4f32ae603c006842496512d5e788eef8f2ce7e215a923bc338a1c55f089a3942476275663a6b2 SHA512 06be60104f23be38578660a79d3c593e988e2c5fce646b00dedec9af4d3442f204f81d063806944cfdaa04daffdff256ac71b52ed94d8ae07acde1e15c442f08
diff --git a/app-containers/grype/grype-0.59.1.ebuild b/app-containers/grype/grype-0.59.1.ebuild
new file mode 100644
index 000000000000..3ce88f7f6d9d
--- /dev/null
+++ b/app-containers/grype/grype-0.59.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_COMMIT=29b646568901d1ef48a528cf35f67f3cead49c9f
+SYFT_VERSION=0.74.1
+
+DESCRIPTION="A vulnerability scanner for container images and filesystems"
+HOMEPAGE="https://www.anchore.com"
+SRC_URI="https://github.com/anchore/grype/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# tests require a running docker
+RESTRICT="test"
+
+src_compile() {
+ ego build -o bin/grype -ldflags "
+ -extldflags '-static'
+ -X github.com/anchore/grype/internal/version.version=${PV}
+ -X github.com/anchore/grype/internal/version.syftVersion=${SYFT_VERSION}
+ -X github.com/anchore/grype/internal/version.gitCommit=${GIT_COMMIT}
+ -X github.com/anchore/grype/internal/version.buildDate=${BUILD_DATE}
+ -X github.com/anchore/grype/internal/version.gitDescription=v${PV}"
+}
+
+src_install() {
+ dobin bin/grype
+}
diff --git a/app-containers/grype/grype-0.61.0.ebuild b/app-containers/grype/grype-0.61.0.ebuild
new file mode 100644
index 000000000000..99ae14b81d3c
--- /dev/null
+++ b/app-containers/grype/grype-0.61.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_COMMIT=d8c0c0805b59659c4d6e49d6806a0eba11bdc2ee
+SYFT_VERSION=0.76.0
+
+DESCRIPTION="A vulnerability scanner for container images and filesystems"
+HOMEPAGE="https://www.anchore.com"
+SRC_URI="https://github.com/anchore/grype/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# tests require a running docker
+RESTRICT="test"
+
+src_compile() {
+ ego build -o bin/grype -ldflags "
+ -extldflags '-static'
+ -X github.com/anchore/grype/internal/version.version=${PV}
+ -X github.com/anchore/grype/internal/version.syftVersion=${SYFT_VERSION}
+ -X github.com/anchore/grype/internal/version.gitCommit=${GIT_COMMIT}
+ -X github.com/anchore/grype/internal/version.buildDate=${BUILD_DATE}
+ -X github.com/anchore/grype/internal/version.gitDescription=v${PV}"
+}
+
+src_install() {
+ dobin bin/grype
+}
diff --git a/app-containers/grype/grype-0.72.0.ebuild b/app-containers/grype/grype-0.72.0.ebuild
new file mode 100644
index 000000000000..acccd2982d3f
--- /dev/null
+++ b/app-containers/grype/grype-0.72.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_COMMIT=04df28051b7694a5e4a28fc5b2ea2068f24ef213
+SYFT_VERSION=0.94.0
+
+DESCRIPTION="A vulnerability scanner for container images and filesystems"
+HOMEPAGE="https://www.anchore.com"
+SRC_URI="https://github.com/anchore/grype/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# tests require a running docker
+RESTRICT="test"
+
+src_compile() {
+ ego build -o bin/grype -ldflags "
+ -extldflags '-static'
+ -X github.com/anchore/grype/internal/version.version=${PV}
+ -X github.com/anchore/grype/internal/version.syftVersion=${SYFT_VERSION}
+ -X github.com/anchore/grype/internal/version.gitCommit=${GIT_COMMIT}
+ -X github.com/anchore/grype/internal/version.buildDate=${BUILD_DATE}
+ -X github.com/anchore/grype/internal/version.gitDescription=v${PV}
+ " ./cmd/grype
+}
+
+src_install() {
+ dobin bin/grype
+}
diff --git a/app-containers/grype/grype-0.73.0.ebuild b/app-containers/grype/grype-0.73.0.ebuild
new file mode 100644
index 000000000000..a2befc0a8c0d
--- /dev/null
+++ b/app-containers/grype/grype-0.73.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_COMMIT=15432488224b3d7a557798fd258828f618dadc90
+SYFT_VERSION=0.95.0
+
+DESCRIPTION="A vulnerability scanner for container images and filesystems"
+HOMEPAGE="https://www.anchore.com"
+SRC_URI="https://github.com/anchore/grype/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# tests require a running docker
+RESTRICT="test"
+
+src_compile() {
+ ego build -o bin/grype -ldflags "
+ -extldflags '-static'
+ -X github.com/anchore/grype/internal/version.version=${PV}
+ -X github.com/anchore/grype/internal/version.syftVersion=${SYFT_VERSION}
+ -X github.com/anchore/grype/internal/version.gitCommit=${GIT_COMMIT}
+ -X github.com/anchore/grype/internal/version.buildDate=${BUILD_DATE}
+ -X github.com/anchore/grype/internal/version.gitDescription=v${PV}
+ " ./cmd/grype
+}
+
+src_install() {
+ dobin bin/grype
+}
diff --git a/app-containers/grype/metadata.xml b/app-containers/grype/metadata.xml
new file mode 100644
index 000000000000..db463f3eeb66
--- /dev/null
+++ b/app-containers/grype/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+</pkgmetadata>