summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/k3d')
-rw-r--r--app-containers/k3d/Manifest2
-rw-r--r--app-containers/k3d/k3d-5.4.9.ebuild39
-rw-r--r--app-containers/k3d/k3d-5.6.0.ebuild39
-rw-r--r--app-containers/k3d/metadata.xml11
4 files changed, 91 insertions, 0 deletions
diff --git a/app-containers/k3d/Manifest b/app-containers/k3d/Manifest
new file mode 100644
index 000000000000..536b64890a4f
--- /dev/null
+++ b/app-containers/k3d/Manifest
@@ -0,0 +1,2 @@
+DIST k3d-5.4.9.tar.gz 7740293 BLAKE2B b7a657720524abac2c36cccef8cf6e9c5588fcc191ecc2a3f7ed138762cc23abdc2b6413c67d426635e50777b8b87fccf93dc7cd88b0dd5c67becbc3f9056472 SHA512 caa6566f79837deb31db991df5475369b4921a5a110b723ad6c76f8ce2349399d0843d3e5de071a4ec50b318157d8fb47cc36018a0af9bb487793269c27027bf
+DIST k3d-5.6.0.tar.gz 8022281 BLAKE2B 93f32f65e6c42650608b94d58d2149c3fec96251500be0d95d5673f07ae8c366d80954afa4d80eec149b7a9e8af7389323c21498910a3010bb80b975f64064d0 SHA512 c13df93499ffde6567e4bf7dcf260cb65ca01c390bf39361122fa61553591f418213049cf29d8dde63896f026a28d96f4e2ab522a143ac66cfa9f3786f8ba9b9
diff --git a/app-containers/k3d/k3d-5.4.9.ebuild b/app-containers/k3d/k3d-5.4.9.ebuild
new file mode 100644
index 000000000000..6f57b743d680
--- /dev/null
+++ b/app-containers/k3d/k3d-5.4.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="k3d creates k3s clusters in docker"
+HOMEPAGE="https://github.com/rancher/k3d"
+
+K3D_K3S_TAG=v1.24.12-k3s1
+SRC_URI="https://github.com/rancher/k3d/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT Apache-2.0 BSD BSD-2 MPL-2.0 ISC"
+SLOT="0"
+
+KEYWORDS="~amd64"
+IUSE="doc"
+
+src_prepare() {
+ default
+ rm Makefile || die
+}
+
+src_compile() {
+ GOWORK=off \
+ CGO_ENABLED=0 \
+ go build \
+ -mod=vendor \
+ -ldflags "-w -s -X github.com/k3d-io/k3d/v5/version.Version=v${PV} -X github.com/k3d-io/k3d/v5/version.K3sVersion=${K3D_K3S_TAG}" \
+ -o bin/k3d
+}
+
+src_install() {
+ dobin bin/${PN}
+ DOCS=(*.md)
+ if use doc; then
+ DOCS+=(docs)
+ fi
+ default_src_install
+}
diff --git a/app-containers/k3d/k3d-5.6.0.ebuild b/app-containers/k3d/k3d-5.6.0.ebuild
new file mode 100644
index 000000000000..1baa48e507e5
--- /dev/null
+++ b/app-containers/k3d/k3d-5.6.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="k3d creates k3s clusters in docker"
+HOMEPAGE="https://github.com/rancher/k3d"
+
+K3D_K3S_TAG=v1.28.3-k3s2
+SRC_URI="https://github.com/rancher/k3d/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT Apache-2.0 BSD BSD-2 MPL-2.0 ISC"
+SLOT="0"
+
+KEYWORDS="~amd64"
+IUSE="doc"
+
+src_prepare() {
+ default
+ rm Makefile || die
+}
+
+src_compile() {
+ GOWORK=off \
+ CGO_ENABLED=0 \
+ go build \
+ -mod=vendor \
+ -ldflags "-w -s -X github.com/k3d-io/k3d/v5/version.Version=v${PV} -X github.com/k3d-io/k3d/v5/version.K3sVersion=${K3D_K3S_TAG}" \
+ -o bin/k3d
+}
+
+src_install() {
+ dobin bin/${PN}
+ DOCS=(*.md)
+ if use doc; then
+ DOCS+=(docs)
+ fi
+ default_src_install
+}
diff --git a/app-containers/k3d/metadata.xml b/app-containers/k3d/metadata.xml
new file mode 100644
index 000000000000..43d8f81ce348
--- /dev/null
+++ b/app-containers/k3d/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ <name>Zac Medico</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rancher/k3d</remote-id>
+ </upstream>
+</pkgmetadata>