summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/lxd/files/lxd-5.0.3-remove-shellcheck-buildsystem-checks.patch')
-rw-r--r--app-containers/lxd/files/lxd-5.0.3-remove-shellcheck-buildsystem-checks.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-containers/lxd/files/lxd-5.0.3-remove-shellcheck-buildsystem-checks.patch b/app-containers/lxd/files/lxd-5.0.3-remove-shellcheck-buildsystem-checks.patch
new file mode 100644
index 000000000000..d3efd72ecb37
--- /dev/null
+++ b/app-containers/lxd/files/lxd-5.0.3-remove-shellcheck-buildsystem-checks.patch
@@ -0,0 +1,33 @@
+diff --git a/Makefile b/Makefile
+index 8061227..c9b85d2 100644
+--- a/Makefile
++++ b/Makefile
+@@ -258,28 +258,6 @@ endif
+ .PHONY: build-mo
+ build-mo: $(MOFILES)
+
+-.PHONY: static-analysis
+-static-analysis:
+-ifeq ($(shell command -v golangci-lint),)
+- curl -sSfL https://raw.githubusercontent.com/golangci/golangci-lint/master/install.sh | sh -s -- -b $$(go env GOPATH)/bin
+-endif
+-ifeq ($(shell command -v shellcheck),)
+- echo "Please install shellcheck"
+- exit 1
+-else
+-ifneq "$(shell shellcheck --version | grep version: | cut -d ' ' -f2)" "0.8.0"
+- @echo "WARN: shellcheck version is not 0.8.0"
+-endif
+-endif
+-ifeq ($(shell command -v flake8),)
+- echo "Please install flake8"
+- exit 1
+-endif
+- flake8 test/deps/import-busybox
+- shellcheck --shell sh test/*.sh test/includes/*.sh test/suites/*.sh test/backends/*.sh test/lint/*.sh
+- shellcheck test/extras/*.sh
+- run-parts --exit-on-error --regex '.sh' test/lint
+-
+ .PHONY: staticcheck
+ staticcheck:
+ ifeq ($(shell command -v staticcheck),)