summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/sen/sen-0.6.1_p20200905-r1.ebuild')
-rw-r--r--app-containers/sen/sen-0.6.1_p20200905-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-containers/sen/sen-0.6.1_p20200905-r1.ebuild b/app-containers/sen/sen-0.6.1_p20200905-r1.ebuild
new file mode 100644
index 000000000000..9f7bf271cf92
--- /dev/null
+++ b/app-containers/sen/sen-0.6.1_p20200905-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+COMMIT="02e5872ee2905861e1da06ab5174e1a3f41f0e0b"
+
+DESCRIPTION="Terminal User Interface for docker engine"
+HOMEPAGE="https://github.com/TomasTomecek/sen"
+SRC_URI="https://github.com/TomasTomecek/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/urwid[${PYTHON_USEDEP}]
+ dev-python/urwidtrees[${PYTHON_USEDEP}]
+ dev-python/docker[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/flexmock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r docs
+}
+
+python_test() {
+ epytest tests
+}