summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/acme-sh')
-rw-r--r--app-crypt/acme-sh/Manifest2
-rw-r--r--app-crypt/acme-sh/acme-sh-3.0.7.ebuild (renamed from app-crypt/acme-sh/acme-sh-3.0.1.ebuild)9
-rw-r--r--app-crypt/acme-sh/acme-sh-9999.ebuild7
3 files changed, 12 insertions, 6 deletions
diff --git a/app-crypt/acme-sh/Manifest b/app-crypt/acme-sh/Manifest
index 713a25283ece..7cfc680ef19a 100644
--- a/app-crypt/acme-sh/Manifest
+++ b/app-crypt/acme-sh/Manifest
@@ -1 +1 @@
-DIST acme.sh-3.0.1.tar.gz 239311 BLAKE2B cbbaf6da068447c3400081889e249dc6f17f56df2038d75915eb990e417ecf5407c9c8272dfbd8403fac413357f30df552678ed27096de769ee5355f6343b6f4 SHA512 8bc5468fa70bf0a23f516b05e49f4c457cceb3ae0c12e963b538297912adce1f16fca200b116fc39a88ee0ba522e1757654ed231bebb6199ef7f5ad152511c71
+DIST acme.sh-3.0.7.tar.gz 284269 BLAKE2B 2e3d81446772049660d3a7b8005b82a890238d33ef16211b304ecd9b996063de9e788095ff958422f90d2e20615f84943d6085959ac2f27d6ad51a8eeffb2800 SHA512 83d080b461662bf2c5cfa9cb51aaf41d7f873f54908e2e5f94d7e3fe8e3f6953d73aafb66adc97455aa958f37c72ef77ba475c7d7cbb3ca3c5bbffb4937c4bae
diff --git a/app-crypt/acme-sh/acme-sh-3.0.1.ebuild b/app-crypt/acme-sh/acme-sh-3.0.7.ebuild
index a6b09a058aa2..321de0c3a864 100644
--- a/app-crypt/acme-sh/acme-sh-3.0.1.ebuild
+++ b/app-crypt/acme-sh/acme-sh-3.0.7.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
MY_PN="${PN/-/.}"
MY_P="${MY_PN}-${PV}"
@@ -10,17 +10,20 @@ inherit optfeature
DESCRIPTION="A pure Unix shell script implementing ACME client protocol"
HOMEPAGE="https://github.com/acmesh-official/acme.sh"
-SRC_URI="https://github.com/acmesh-official/${MY_PN}/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+SRC_URI="https://github.com/acmesh-official/${MY_PN}/archive/refs/tags/${PV}.tar.gz -> ${MY_P}.tar.gz"
S="${WORKDIR}/${MY_P}"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="selinux"
+
RDEPEND="
dev-libs/openssl:0
net-misc/curl
net-misc/socat
+ selinux? ( sec-policy/selinux-certbot )
"
src_install() {
diff --git a/app-crypt/acme-sh/acme-sh-9999.ebuild b/app-crypt/acme-sh/acme-sh-9999.ebuild
index 978b348479ac..25fe72160c37 100644
--- a/app-crypt/acme-sh/acme-sh-9999.ebuild
+++ b/app-crypt/acme-sh/acme-sh-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit git-r3 optfeature
@@ -13,10 +13,13 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
+IUSE="selinux"
+
RDEPEND="
dev-libs/openssl:0
net-misc/curl
net-misc/socat
+ selinux? ( sec-policy/selinux-certbot )
"
src_install() {