summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/acme-tiny')
-rw-r--r--app-crypt/acme-tiny/Manifest2
-rw-r--r--app-crypt/acme-tiny/acme-tiny-5.0.1-r1.ebuild (renamed from app-crypt/acme-tiny/acme-tiny-4.1.0.ebuild)14
-rw-r--r--app-crypt/acme-tiny/acme-tiny-5.0.1-r2.ebuild35
-rw-r--r--app-crypt/acme-tiny/acme-tiny-9999.ebuild47
-rw-r--r--app-crypt/acme-tiny/metadata.xml13
5 files changed, 52 insertions, 59 deletions
diff --git a/app-crypt/acme-tiny/Manifest b/app-crypt/acme-tiny/Manifest
index 10ca796d5030..beb4c6083b4b 100644
--- a/app-crypt/acme-tiny/Manifest
+++ b/app-crypt/acme-tiny/Manifest
@@ -1 +1 @@
-DIST acme-tiny-4.1.0.tar.gz 12776 BLAKE2B 7efd9d1399ec3bbd98180511c9f36fbf6f9a96a0d4e0e72b9d4c85d16246118eaaad25bc26ba42f746fd4b60b498ceca5307e279d788157237ac6ad153848501 SHA512 31d69a5031c019acbc23b3f06041eae8e261766396d4a7420fd70a71cfa16de953bea4c0c2ad0c6a6e793ed61ab5331f40145352ffce69f4f062f35dd0db7519
+DIST acme-tiny-5.0.1.tar.gz 21036 BLAKE2B a09c16ca19570b48d34c919e2a361e3be5d66ed8fc0ccff7af74e4018d294f2940a552906dee45bac27a16e7b039a3567dc35e201b058015c5123baa2cbb01c1 SHA512 6e0619917b31a5795c2c7d8aa811b46231b81fc6b57227f611f7f4b9f73eb3de669676482563c33d935a4a0812498677bcbe974663a561af61abb441a880947e
diff --git a/app-crypt/acme-tiny/acme-tiny-4.1.0.ebuild b/app-crypt/acme-tiny/acme-tiny-5.0.1-r1.ebuild
index d019da939aa5..41eb33d55d23 100644
--- a/app-crypt/acme-tiny/acme-tiny-4.1.0.ebuild
+++ b/app-crypt/acme-tiny/acme-tiny-5.0.1-r1.ebuild
@@ -1,9 +1,12 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+PYTHON_COMPAT=( python{3_9,3_10,3_11} )
+
+DISTUTILS_USE_PEP517="setuptools"
-PYTHON_COMPAT=( python{3_7,3_8,3_9} )
inherit distutils-r1
if [[ ${PV} == 9999 ]]; then
@@ -21,9 +24,12 @@ LICENSE="MIT"
SLOT="0"
IUSE=""
-DEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools-scm[${PYTHON_USEDEP}]"
RDEPEND="dev-libs/openssl:0"
+# Tests require a local ACME server to be set up.
+RESTRICT="test"
+
pkg_setup() {
if [[ ${PV} != 9999 ]]; then
export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
diff --git a/app-crypt/acme-tiny/acme-tiny-5.0.1-r2.ebuild b/app-crypt/acme-tiny/acme-tiny-5.0.1-r2.ebuild
new file mode 100644
index 000000000000..248ebad7185f
--- /dev/null
+++ b/app-crypt/acme-tiny/acme-tiny-5.0.1-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python{3_10,3_11,3_12} )
+
+DISTUTILS_USE_PEP517="setuptools"
+
+inherit distutils-r1
+
+SRC_URI="https://github.com/diafygi/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="A tiny, auditable script for Let's Encrypt's ACME Protocol"
+HOMEPAGE="https://github.com/diafygi/acme-tiny"
+
+LICENSE="MIT"
+SLOT="0"
+
+BDEPEND="dev-python/setuptools-scm[${PYTHON_USEDEP}]"
+RDEPEND="dev-libs/openssl:0"
+
+# Tests require a local ACME server to be set up.
+RESTRICT="test"
+
+pkg_setup() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
+}
+
+src_prepare() {
+ sed -i 's|#!/usr/bin/sh|#!/bin/sh|g' README.md || die
+
+ distutils-r1_src_prepare
+}
diff --git a/app-crypt/acme-tiny/acme-tiny-9999.ebuild b/app-crypt/acme-tiny/acme-tiny-9999.ebuild
deleted file mode 100644
index 5c6c1c7e6e6b..000000000000
--- a/app-crypt/acme-tiny/acme-tiny-9999.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{3_7,3_8,3_9} )
-inherit distutils-r1
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/diafygi/${PN}.git"
-else
- SRC_URI="https://github.com/diafygi/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="A tiny, auditable script for Let's Encrypt's ACME Protocol"
-HOMEPAGE="https://github.com/diafygi/acme-tiny"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE=""
-
-DEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]"
-RDEPEND="dev-libs/openssl:0"
-
-pkg_setup() {
- if [[ ${PV} != 9999 ]]; then
- export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
- fi
-}
-
-src_prepare() {
- sed -i 's|#!/usr/bin/sh|#!/bin/sh|g' README.md || die
-
- distutils-r1_src_prepare
-}
-
-pkg_postinst() {
- for v in ${REPLACING_VERSIONS}; do
- if ver_test "$v" "-lt" "4.0.3" || ver_test "$v" "-ge" "9999"; then
- einfo "The --account-email flag has been changed to --contact and"
- einfo "has different syntax."
- einfo "Please update your scripts accordingly"
- fi
- done
-}
diff --git a/app-crypt/acme-tiny/metadata.xml b/app-crypt/acme-tiny/metadata.xml
index 61c31881866c..418b25e0fbfe 100644
--- a/app-crypt/acme-tiny/metadata.xml
+++ b/app-crypt/acme-tiny/metadata.xml
@@ -1,11 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>np-hardass@gentoo.org</email>
- <name>Adam Feldman</name>
- </maintainer>
- <upstream>
- <remote-id type="github">diafygi/acme-tiny</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>graaff@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">diafygi/acme-tiny</remote-id>
+ </upstream>
</pkgmetadata>