summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/acme/acme-0.0.0_pre20151123.ebuild')
-rw-r--r--app-crypt/acme/acme-0.0.0_pre20151123.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-crypt/acme/acme-0.0.0_pre20151123.ebuild b/app-crypt/acme/acme-0.0.0_pre20151123.ebuild
new file mode 100644
index 000000000000..cdd87cd8e6f0
--- /dev/null
+++ b/app-crypt/acme/acme-0.0.0_pre20151123.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="letsencrypt"
+MY_PV="${PV/_pre/.dev}"
+MY_P="${MY_PN}-${MY_PV}"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/letsencrypt/letsencrypt.git"
+ inherit git-r3 distutils-r1
+else
+ SRC_URI="https://github.com/letsencrypt/letsencrypt/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="An implementation of the ACME protocol"
+HOMEPAGE="https://github.com/letsencrypt/letsencrypt https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=dev-python/cryptography-0.8[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/ndg-httpsclient-0.4[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.15[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}/${PN}"
+
+python_test() {
+ nosetests -w ${PN} || die
+}