summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/aescrypt/files/aescrypt-3.14-ldflags.patch')
-rw-r--r--app-crypt/aescrypt/files/aescrypt-3.14-ldflags.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/app-crypt/aescrypt/files/aescrypt-3.14-ldflags.patch b/app-crypt/aescrypt/files/aescrypt-3.14-ldflags.patch
new file mode 100644
index 000000000000..757f0e4e7fcb
--- /dev/null
+++ b/app-crypt/aescrypt/files/aescrypt-3.14-ldflags.patch
@@ -0,0 +1,20 @@
+diff -Naru a/src/Makefile b/src/Makefile
+--- a/src/Makefile 2021-07-14 09:25:15.509797042 +0200
++++ b/src/Makefile 2021-07-14 09:25:46.689797121 +0200
+@@ -27,13 +27,13 @@
+ all: aescrypt aescrypt_keygen
+
+ aescrypt: $(AESCRYPT_OBJS)
+- $(CC) $(CFLAGS) $(LIBS) -o $@ $(AESCRYPT_OBJS)
++ $(CC) $(CFLAGS) $(LIBS) $(LDFLAGS) -o $@ $(AESCRYPT_OBJS)
+
+ aescrypt_keygen: $(KEYGEN_OBJS)
+- $(CC) $(CFLAGS) $(LIBS) -o $@ $(KEYGEN_OBJS)
++ $(CC) $(CFLAGS) $(LIBS) $(LDFLAGS) -o $@ $(KEYGEN_OBJS)
+
+ %.o: %.c %.h
+- $(CC) $(CFLAGS) -c $*.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -c $*.c
+
+ install: aescrypt
+ install -o root -g root -m 755 aescrypt /usr/bin