summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/aespipe/aespipe-2.4f-r1.ebuild')
-rw-r--r--app-crypt/aespipe/aespipe-2.4f-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-crypt/aespipe/aespipe-2.4f-r1.ebuild b/app-crypt/aespipe/aespipe-2.4f-r1.ebuild
new file mode 100644
index 000000000000..c8ed90346146
--- /dev/null
+++ b/app-crypt/aespipe/aespipe-2.4f-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="Encrypts data from stdin to stdout"
+HOMEPAGE="https://loop-aes.sourceforge.net"
+SRC_URI="https://loop-aes.sourceforge.net/aespipe/${PN}-v${PV}.tar.bz2"
+S="${WORKDIR}/${PN}-v${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="+asm cpu_flags_x86_aes cpu_flags_x86_padlock static"
+
+RDEPEND="
+ app-arch/sharutils
+ app-crypt/gnupg"
+
+src_configure() {
+ use static && append-ldflags -static
+ econf \
+ $(use_enable asm) \
+ $(use_enable cpu_flags_x86_aes intelaes) \
+ $(use_enable cpu_flags_x86_padlock padlock)
+}