summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/ccid')
-rw-r--r--app-crypt/ccid/Manifest5
-rw-r--r--app-crypt/ccid/ccid-1.4.35.ebuild61
-rw-r--r--app-crypt/ccid/ccid-1.4.36.ebuild61
-rw-r--r--app-crypt/ccid/ccid-1.5.1.ebuild45
-rw-r--r--app-crypt/ccid/ccid-1.5.4.ebuild55
-rw-r--r--app-crypt/ccid/ccid-1.5.5.ebuild55
-rw-r--r--app-crypt/ccid/files/92_pcscd_ccid-2.rules50
-rw-r--r--app-crypt/ccid/files/ccid-1.5.4-remove-flex-configure-dependency.patch16
-rw-r--r--app-crypt/ccid/files/ccid-1.5.5-remove-flex-configure-dependency.patch13
-rw-r--r--app-crypt/ccid/metadata.xml11
10 files changed, 194 insertions, 178 deletions
diff --git a/app-crypt/ccid/Manifest b/app-crypt/ccid/Manifest
index b5271c5e6380..e6910d3ce7d2 100644
--- a/app-crypt/ccid/Manifest
+++ b/app-crypt/ccid/Manifest
@@ -1,2 +1,3 @@
-DIST ccid-1.4.35.tar.bz2 676789 BLAKE2B d1123c024a798a22906a5c2c2e35f5485b8d2252ddec28571af835bbf169bc5abeb26fea871ef70d67270cc1eb52f992c56f0abb74f6deed555f15e39dbf4756 SHA512 da990b5537ec35baa1b36b9c4be7f1bdccfc149cfa4ce024ddf59504f2a2044273057c1454f227fdad8f6b04fceaf48b88e70d4d0a5475384749b367529deaeb
-DIST ccid-1.4.36.tar.bz2 677047 BLAKE2B b3d48f1c51b64d260b7055251fb04aeea4a22cc5d4f024bb972a9a9874b1bdf4b75b9daf8cd7c9f26000b04e7d4c1779e20a26d4927aa1e403cd274f548b71b5 SHA512 e9ca3f5364c6cec988edad325c1ef1b35886e3ecb15d6e1409c989b9f669fbda3f0688e246e3976b58eacc0ed035cde36e65675abf12562e81c3630d4ce67773
+DIST ccid-1.5.1.tar.bz2 702586 BLAKE2B 7b9e3c6daf03c186f34ac9b13bd960293a6481f9237ee52937ece1040bd3a79b7dab318e1244205a7feae992261ab5e82292d80ae023a4f621e0e7af7cdb9df5 SHA512 492bde96f5752e2a5316693c44e35e2d041785a00d15e094905c0aafad392f5329009d12801899367276328a582936ee53a1c5239c1813c4536001cb8a608f2e
+DIST ccid-1.5.4.tar.bz2 706834 BLAKE2B 8b7f08145808ac94d085eef62c204f8146892cb11f2ce811e46e674272cab016d602afb945c6e808ce3957a80e847c0de2815fedaf15fc8c935cafaccf102762 SHA512 4b30f4768aebf49486a1b1e959615fa077bd393bfdd9e52c15bdc8d6ed63ce27fa7cf82a067d1f80d8b3534c66194036925d3fea5af64b6a775779d38267c757
+DIST ccid-1.5.5.tar.bz2 708374 BLAKE2B a82986ead2dbb3241ef419ad16eb0fac835c5ab4fa988e5ee53cd1608a30a9381210a6fd013b6a059ca2835d55b4a41afa4064575e91b8eb356bff6d01d19add SHA512 9d2aebe645a5880bfad7d420ddab96811d1fd989c79afa28f5471ae53f36b6d45ee5e13b32ac4afcf59fc762ae835db7e6312ad6642b263158c2d9a30c7651bd
diff --git a/app-crypt/ccid/ccid-1.4.35.ebuild b/app-crypt/ccid/ccid-1.4.35.ebuild
deleted file mode 100644
index 680c83b8ed8a..000000000000
--- a/app-crypt/ccid/ccid-1.4.35.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs udev
-
-DESCRIPTION="CCID free software driver"
-HOMEPAGE="https://ccid.apdu.fr https://github.com/LudovicRousseau/CCID"
-SRC_URI="https://ccid.apdu.fr/files/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ppc ppc64 ~riscv ~sparc x86"
-IUSE="twinserial kobil-midentity +usb"
-
-RDEPEND=">=sys-apps/pcsc-lite-1.8.3
- usb? ( virtual/libusb:1 )"
-DEPEND="${RDEPEND}"
-BDEPEND="kernel_linux? ( virtual/pkgconfig )"
-
-DOCS=( README.md AUTHORS )
-
-src_configure() {
- econf \
- LEX=: \
- $(use_enable twinserial) \
- $(use_enable usb libusb)
-}
-
-src_compile() {
- default
- use kobil-midentity && emake -C contrib/Kobil_mIDentity_switch
-}
-
-src_install() {
- default
-
- if use kobil-midentity; then
- dosbin contrib/Kobil_mIDentity_switch/Kobil_mIDentity_switch
- doman contrib/Kobil_mIDentity_switch/Kobil_mIDentity_switch.8
- fi
-
- if use kernel_linux; then
- # note: for eudev support, rules probably will always need to be
- # installed to /usr
-
- # ccid >=1.4.11 version changed the rules drastically in a minor
- # release to no longer use the pcscd group. Using the old ones in
- # the mean time.
- udev_newrules "${FILESDIR}"/92_pcscd_ccid-2.rules 92-pcsc-ccid.rules
-
- # disable Kobil_mIDentity_switch udev rule with USE=-kobil-midentity
- if ! use kobil-midentity; then
- sed \
- -e '/Kobil_mIDentity_switch/s/^/#/' \
- -i "${D}/$(get_udevdir)"/rules.d/92-pcsc-ccid.rules || die
- fi
-
- fi
-}
diff --git a/app-crypt/ccid/ccid-1.4.36.ebuild b/app-crypt/ccid/ccid-1.4.36.ebuild
deleted file mode 100644
index fb17ec0a07ed..000000000000
--- a/app-crypt/ccid/ccid-1.4.36.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs udev
-
-DESCRIPTION="CCID free software driver"
-HOMEPAGE="https://ccid.apdu.fr https://github.com/LudovicRousseau/CCID"
-SRC_URI="https://ccid.apdu.fr/files/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
-IUSE="twinserial kobil-midentity +usb"
-
-RDEPEND=">=sys-apps/pcsc-lite-1.8.3
- usb? ( virtual/libusb:1 )"
-DEPEND="${RDEPEND}"
-BDEPEND="kernel_linux? ( virtual/pkgconfig )"
-
-DOCS=( README.md AUTHORS )
-
-src_configure() {
- econf \
- LEX=: \
- $(use_enable twinserial) \
- $(use_enable usb libusb)
-}
-
-src_compile() {
- default
- use kobil-midentity && emake -C contrib/Kobil_mIDentity_switch
-}
-
-src_install() {
- default
-
- if use kobil-midentity; then
- dosbin contrib/Kobil_mIDentity_switch/Kobil_mIDentity_switch
- doman contrib/Kobil_mIDentity_switch/Kobil_mIDentity_switch.8
- fi
-
- if use kernel_linux; then
- # note: for eudev support, rules probably will always need to be
- # installed to /usr
-
- # ccid >=1.4.11 version changed the rules drastically in a minor
- # release to no longer use the pcscd group. Using the old ones in
- # the mean time.
- udev_newrules "${FILESDIR}"/92_pcscd_ccid-2.rules 92-pcsc-ccid.rules
-
- # disable Kobil_mIDentity_switch udev rule with USE=-kobil-midentity
- if ! use kobil-midentity; then
- sed \
- -e '/Kobil_mIDentity_switch/s/^/#/' \
- -i "${D}/$(get_udevdir)"/rules.d/92-pcsc-ccid.rules || die
- fi
-
- fi
-}
diff --git a/app-crypt/ccid/ccid-1.5.1.ebuild b/app-crypt/ccid/ccid-1.5.1.ebuild
new file mode 100644
index 000000000000..d2baa0389016
--- /dev/null
+++ b/app-crypt/ccid/ccid-1.5.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit udev
+
+DESCRIPTION="CCID free software driver"
+HOMEPAGE="https://ccid.apdu.fr https://github.com/LudovicRousseau/CCID"
+SRC_URI="https://ccid.apdu.fr/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~sparc x86"
+IUSE="twinserial +usb"
+
+RDEPEND="
+ >=sys-apps/pcsc-lite-1.8.3
+ twinserial? ( dev-lang/perl )
+ usb? ( virtual/libusb:1 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ LEX=: \
+ $(use_enable twinserial) \
+ $(use_enable usb libusb)
+}
+
+src_install() {
+ default
+ udev_newrules src/92_pcscd_ccid.rules 92-pcsc-ccid.rules
+}
+
+pkg_postinst() {
+ udev_reload
+ einfo "Check https://github.com/LudovicRousseau/CCID/blob/master/INSTALL"
+ einfo "for more info about how to configure and use ccid"
+}
+
+pkg_postrm() {
+ udev_reload
+}
diff --git a/app-crypt/ccid/ccid-1.5.4.ebuild b/app-crypt/ccid/ccid-1.5.4.ebuild
new file mode 100644
index 000000000000..6652a82c38c2
--- /dev/null
+++ b/app-crypt/ccid/ccid-1.5.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools udev
+
+DESCRIPTION="CCID free software driver"
+HOMEPAGE="https://ccid.apdu.fr https://github.com/LudovicRousseau/CCID"
+SRC_URI="https://ccid.apdu.fr/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~sparc x86"
+IUSE="twinserial +usb"
+
+RDEPEND="
+ >=sys-apps/pcsc-lite-1.8.3
+ twinserial? ( dev-lang/perl )
+ usb? ( virtual/libusb:1 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-remove-flex-configure-dependency.patch
+)
+
+src_prepare() {
+ default
+
+ eautoconf
+}
+
+src_configure() {
+ econf \
+ LEX=: \
+ $(use_enable twinserial) \
+ $(use_enable usb libusb)
+}
+
+src_install() {
+ default
+ udev_newrules src/92_pcscd_ccid.rules 92-pcsc-ccid.rules
+}
+
+pkg_postinst() {
+ udev_reload
+ einfo "Check https://github.com/LudovicRousseau/CCID/blob/master/INSTALL"
+ einfo "for more info about how to configure and use ccid"
+}
+
+pkg_postrm() {
+ udev_reload
+}
diff --git a/app-crypt/ccid/ccid-1.5.5.ebuild b/app-crypt/ccid/ccid-1.5.5.ebuild
new file mode 100644
index 000000000000..d701d5ebd5cf
--- /dev/null
+++ b/app-crypt/ccid/ccid-1.5.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools udev
+
+DESCRIPTION="CCID free software driver"
+HOMEPAGE="https://ccid.apdu.fr https://github.com/LudovicRousseau/CCID"
+SRC_URI="https://ccid.apdu.fr/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="twinserial +usb"
+
+RDEPEND="
+ >=sys-apps/pcsc-lite-1.8.3
+ twinserial? ( dev-lang/perl )
+ usb? ( virtual/libusb:1 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-remove-flex-configure-dependency.patch
+)
+
+src_prepare() {
+ default
+
+ eautoconf
+}
+
+src_configure() {
+ econf \
+ LEX=: \
+ $(use_enable twinserial) \
+ $(use_enable usb libusb)
+}
+
+src_install() {
+ default
+ udev_newrules src/92_pcscd_ccid.rules 92-pcsc-ccid.rules
+}
+
+pkg_postinst() {
+ udev_reload
+ einfo "Check https://github.com/LudovicRousseau/CCID/blob/master/INSTALL"
+ einfo "for more info about how to configure and use ccid"
+}
+
+pkg_postrm() {
+ udev_reload
+}
diff --git a/app-crypt/ccid/files/92_pcscd_ccid-2.rules b/app-crypt/ccid/files/92_pcscd_ccid-2.rules
deleted file mode 100644
index ca4d1ce1b729..000000000000
--- a/app-crypt/ccid/files/92_pcscd_ccid-2.rules
+++ /dev/null
@@ -1,50 +0,0 @@
-# udev rules to set the access rights of CCID smart card readers
-# so they can be used by pcscd
-
-# $Id: 92_pcscd_ccid.rules 6587 2013-04-05 16:31:55Z rousseau $
-
-# Gemplus PCMCIA Card
-#SUBSYSTEMS=="pcmcia", DRIVERS=="serial_cs", ACTION=="add", ATTRS{prod_id1}=="Gemplus", ATTRS{prod_id2}=="SerialPort", ATTRS{prod_id3}=="GemPC Card", RUN+="/usr/sbin/pcscd --hotplug"
-
-# If not adding the device, go away
-ACTION!="add", GOTO="pcscd_ccid_rules_end"
-SUBSYSTEM!="usb", GOTO="pcscd_ccid_rules_end"
-ENV{DEVTYPE}!="usb_device", GOTO="pcscd_ccid_rules_end"
-
-# Kobil mIDentity
-ATTRS{idVendor}=="0d46", ATTRS{idProduct}=="4081", RUN+="/usr/sbin/Kobil_mIDentity_switch"
-
-# generic CCID device (bInterfaceClass = 0x0b)
-# change group from default "root" to "pcscd"
-ENV{ID_USB_INTERFACES}=="*:0b0000:*", ENV{PCSCD}="1"
-
-# set USB power management to auto. "power/level" has been deprecated in
-# Linux 2.6.35 and replaced by "power/control"
-ENV{ID_USB_INTERFACES}==":0b0000:", RUN+="/bin/sh -c 'if test -e /sys/$env{DEVPATH}/power/control; then echo auto > /sys/$env{DEVPATH}/power/control; elif test -e /sys/$env{DEVPATH}/power/level; then echo auto > /sys/$env{DEVPATH}/power/level; fi'"
-
-# non CCID generic (InterfaceClass: 0xFF)
-# CherrySmartTerminalST2XXX.txt
-ATTRS{idVendor}=="046a", ATTRS{idProduct}=="003e", ENV{PCSCD}="1"
-# DellSK-3106.txt
-ATTRS{idVendor}=="413c", ATTRS{idProduct}=="2100", ENV{PCSCD}="1"
-# MySmartPad.txt
-ATTRS{idVendor}=="09be", ATTRS{idProduct}=="0002", ENV{PCSCD}="1"
-# SCR3310-NTTCom USB SmartCard Reader
-ATTRS{idVendor}=="04e6", ATTRS{idProduct}=="511a", ENV{PCSCD}="1"
-# SCR331-DI USB Smart Card Reader
-ATTRS{idVendor}=="04e6", ATTRS{idProduct}=="5120", ENV{PCSCD}="1"
-# SCR331-DI.txt
-ATTRS{idVendor}=="04e6", ATTRS{idProduct}=="5111", ENV{PCSCD}="1"
-# SDI010.txt
-ATTRS{idVendor}=="04e6", ATTRS{idProduct}=="5121", ENV{PCSCD}="1"
-# SPR532.txt
-ATTRS{idVendor}=="04e6", ATTRS{idProduct}=="e003", ENV{PCSCD}="1"
-# Verisign_secure_storage_token.txt
-ATTRS{idVendor}=="08e6", ATTRS{idProduct}=="1359", ENV{PCSCD}="1"
-# Verisign_secure_token.txt
-ATTRS{idVendor}=="08e6", ATTRS{idProduct}=="ace0", ENV{PCSCD}="1"
-# SchlumbergerSema Cyberflex Access e-gate
-ATTRS{idVendor}=="0973", ATTRS{idProduct}=="0003", ENV{PCSCD}="1"
-
-# All done
-LABEL="pcscd_ccid_rules_end"
diff --git a/app-crypt/ccid/files/ccid-1.5.4-remove-flex-configure-dependency.patch b/app-crypt/ccid/files/ccid-1.5.4-remove-flex-configure-dependency.patch
new file mode 100644
index 000000000000..564532c9ab42
--- /dev/null
+++ b/app-crypt/ccid/files/ccid-1.5.4-remove-flex-configure-dependency.patch
@@ -0,0 +1,16 @@
+Bug: https://bugs.gentoo.org/221361
+Reverts upstream commit eec7cdf0
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -32,11 +32,6 @@ AC_PROG_CPP
+ AC_PROG_INSTALL
+ AC_PROG_MAKE_SET
+ AC_PROG_LN_S
+-AC_PROG_LEX([noyywrap])
+-if test $LEX = ":"
+-then
+- AC_MSG_ERROR([no lex or flex found])
+-fi
+ AM_PROG_AR
+ PKG_PROG_PKG_CONFIG
diff --git a/app-crypt/ccid/files/ccid-1.5.5-remove-flex-configure-dependency.patch b/app-crypt/ccid/files/ccid-1.5.5-remove-flex-configure-dependency.patch
new file mode 100644
index 000000000000..a124c50d1161
--- /dev/null
+++ b/app-crypt/ccid/files/ccid-1.5.5-remove-flex-configure-dependency.patch
@@ -0,0 +1,13 @@
+Bug: https://bugs.gentoo.org/221361
+Reverts upstream commit eec7cdf0 & 41270c2
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -33,7 +33,5 @@
+ AC_PROG_MAKE_SET
+ AC_PROG_LN_S
+-AC_PROG_LEX([noyywrap])
+-AS_IF([test $LEX = ":"], [AC_MSG_ERROR([no lex or flex found])])
+ AM_PROG_AR
+ PKG_PROG_PKG_CONFIG
+
diff --git a/app-crypt/ccid/metadata.xml b/app-crypt/ccid/metadata.xml
index 6931ac359b4d..5e0f0fdc1d2a 100644
--- a/app-crypt/ccid/metadata.xml
+++ b/app-crypt/ccid/metadata.xml
@@ -1,12 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>zlogene@gentoo.org</email>
- <name>Mikle Kolyada</name>
+ <maintainer type="person" proxied="yes">
+ <email>turret@turret.cyou</email>
+ <name>Mason Rocha</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
</maintainer>
<use>
- <flag name="kobil-midentity">Build and install Kobil_mIDentity_switch tool</flag>
<flag name="twinserial">Enable twinserial reader</flag>
</use>
<upstream>