summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/certbot-dns-dnsimple/certbot-dns-dnsimple-2.10.0.ebuild')
-rw-r--r--app-crypt/certbot-dns-dnsimple/certbot-dns-dnsimple-2.10.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-crypt/certbot-dns-dnsimple/certbot-dns-dnsimple-2.10.0.ebuild b/app-crypt/certbot-dns-dnsimple/certbot-dns-dnsimple-2.10.0.ebuild
new file mode 100644
index 000000000000..49462ea339f0
--- /dev/null
+++ b/app-crypt/certbot-dns-dnsimple/certbot-dns-dnsimple-2.10.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="DNSimple Authenticator plugin for Certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://certbot-dns-dnsimple.readthedocs.io/en/stable/"
+# Use common certbot tarball
+SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.gh.tar.gz"
+
+S="${WORKDIR}/certbot-${PV}/${PN}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/dns-lexicon-3.2.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest