summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/certbot-dns-dnsimple')
-rw-r--r--app-crypt/certbot-dns-dnsimple/Manifest2
-rw-r--r--app-crypt/certbot-dns-dnsimple/certbot-dns-dnsimple-2.10.0.ebuild29
-rw-r--r--app-crypt/certbot-dns-dnsimple/certbot-dns-dnsimple-2.6.0.ebuild29
-rw-r--r--app-crypt/certbot-dns-dnsimple/metadata.xml17
4 files changed, 77 insertions, 0 deletions
diff --git a/app-crypt/certbot-dns-dnsimple/Manifest b/app-crypt/certbot-dns-dnsimple/Manifest
new file mode 100644
index 000000000000..e8c21bb48bdc
--- /dev/null
+++ b/app-crypt/certbot-dns-dnsimple/Manifest
@@ -0,0 +1,2 @@
+DIST certbot-2.10.0.gh.tar.gz 2322931 BLAKE2B cb84815ec2db2b4b365f2f2bdee1749263b540a1b67f9195280bdb122307337d294beb403bc05b236a94ed0782b0d093e2b8527a65cb69cac949fa627388e8bd SHA512 444981952140376808a9aa475a692df91e60fffc6d45902a3f809bc07311a7d6597ad56e712d3dae234450eb1c735db431182e784bc748511e68bf4f5f2d6cbd
+DIST certbot-2.6.0.gh.tar.gz 1336339 BLAKE2B 0c0575ad553ebe0f3ab56da750572bca46b30d034033e43c30c3793c114050ad824a277eab0be5a47326ea099e58e9a421448b53fc1b9173afae9a0ec308ac62 SHA512 d694156886484511f5a38fb5e40f98b2e2dbe4bc5110c95b2084ec03b39cb0eb9bbc623c7bca4a81054e980c8dbac752949042391813298a27be7e70410882e3
diff --git a/app-crypt/certbot-dns-dnsimple/certbot-dns-dnsimple-2.10.0.ebuild b/app-crypt/certbot-dns-dnsimple/certbot-dns-dnsimple-2.10.0.ebuild
new file mode 100644
index 000000000000..49462ea339f0
--- /dev/null
+++ b/app-crypt/certbot-dns-dnsimple/certbot-dns-dnsimple-2.10.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="DNSimple Authenticator plugin for Certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://certbot-dns-dnsimple.readthedocs.io/en/stable/"
+# Use common certbot tarball
+SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.gh.tar.gz"
+
+S="${WORKDIR}/certbot-${PV}/${PN}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/dns-lexicon-3.2.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
diff --git a/app-crypt/certbot-dns-dnsimple/certbot-dns-dnsimple-2.6.0.ebuild b/app-crypt/certbot-dns-dnsimple/certbot-dns-dnsimple-2.6.0.ebuild
new file mode 100644
index 000000000000..9169bbe14d00
--- /dev/null
+++ b/app-crypt/certbot-dns-dnsimple/certbot-dns-dnsimple-2.6.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="DNSimple Authenticator plugin for Certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://certbot-dns-dnsimple.readthedocs.io/en/stable/"
+# Use common certbot tarball
+SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.gh.tar.gz"
+
+S="${WORKDIR}/certbot-${PV}/${PN}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/dns-lexicon-3.2.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
diff --git a/app-crypt/certbot-dns-dnsimple/metadata.xml b/app-crypt/certbot-dns-dnsimple/metadata.xml
new file mode 100644
index 000000000000..0d75ba589015
--- /dev/null
+++ b/app-crypt/certbot-dns-dnsimple/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>azamat.hackimov@gmail.com</email>
+ <name>Azamat H. Hackimov</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">certbot/certbot</remote-id>
+ <remote-id type="pypi">certbot-dns-dnsimple</remote-id>
+ </upstream>
+</pkgmetadata>