summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/certbot/certbot-1.6.0.ebuild')
-rw-r--r--app-crypt/certbot/certbot-1.6.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-crypt/certbot/certbot-1.6.0.ebuild b/app-crypt/certbot/certbot-1.6.0.ebuild
new file mode 100644
index 000000000000..f5147fca7936
--- /dev/null
+++ b/app-crypt/certbot/certbot-1.6.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{3_6,3_7,3_8})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+S=${WORKDIR}/${P}/${PN}
+
+inherit distutils-r1
+
+DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ ${CDEPEND}
+ >=app-crypt/acme-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.8[${PYTHON_USEDEP}]
+ >=dev-python/distro-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-1.3[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # required as deps of deps can trigger this too...
+ echo ' ignore:.*collections\.abc:DeprecationWarning' >> ../pytest.ini
+ distutils-r1_python_prepare_all
+}