summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/chntpw/chntpw-140201-r1.ebuild')
-rw-r--r--app-crypt/chntpw/chntpw-140201-r1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-crypt/chntpw/chntpw-140201-r1.ebuild b/app-crypt/chntpw/chntpw-140201-r1.ebuild
index 2aeae846a75b..8594fba742f8 100644
--- a/app-crypt/chntpw/chntpw-140201-r1.ebuild
+++ b/app-crypt/chntpw/chntpw-140201-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Offline Windows NT Password & Registry Editor"
HOMEPAGE="https://pogostick.net/~pnh/ntpasswd/"
@@ -34,6 +34,9 @@ src_prepare() {
default
sed -i -e '/-o/s:$(CC):$(CC) $(LDFLAGS):' Makefile || die
+ # MANY changes would be required for this code to be c99-compliant
+ append-flags -std=gnu90
+
if ! use static ; then
sed -i -e "/^all:/s/ \(chntpw\|reged\).static//g" Makefile || die
fi