summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/chntpw')
-rw-r--r--app-crypt/chntpw/chntpw-140201-r1.ebuild (renamed from app-crypt/chntpw/chntpw-140201.ebuild)17
-rw-r--r--app-crypt/chntpw/files/chntpw-140201-missing-stdint.patch26
-rw-r--r--app-crypt/chntpw/metadata.xml2
3 files changed, 39 insertions, 6 deletions
diff --git a/app-crypt/chntpw/chntpw-140201.ebuild b/app-crypt/chntpw/chntpw-140201-r1.ebuild
index 9e452d567995..8594fba742f8 100644
--- a/app-crypt/chntpw/chntpw-140201.ebuild
+++ b/app-crypt/chntpw/chntpw-140201-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Offline Windows NT Password & Registry Editor"
HOMEPAGE="https://pogostick.net/~pnh/ntpasswd/"
@@ -26,10 +26,17 @@ DOCS=(
regedit.txt
)
+PATCHES=(
+ "${FILESDIR}"/${P}-missing-stdint.patch
+)
+
src_prepare() {
default
sed -i -e '/-o/s:$(CC):$(CC) $(LDFLAGS):' Makefile || die
+ # MANY changes would be required for this code to be c99-compliant
+ append-flags -std=gnu90
+
if ! use static ; then
sed -i -e "/^all:/s/ \(chntpw\|reged\).static//g" Makefile || die
fi
@@ -46,9 +53,9 @@ src_compile() {
src_install() {
einstalldocs
- dobin chntpw cpnt reged
+ dobin chntpw cpnt reged sampasswd samusrgrp
if use static; then
- dobin {chntpw,reged}.static
+ dobin {chntpw,reged,sampasswd,samusrgrp}.static
fi
}
diff --git a/app-crypt/chntpw/files/chntpw-140201-missing-stdint.patch b/app-crypt/chntpw/files/chntpw-140201-missing-stdint.patch
new file mode 100644
index 000000000000..de33ebff0659
--- /dev/null
+++ b/app-crypt/chntpw/files/chntpw-140201-missing-stdint.patch
@@ -0,0 +1,26 @@
+From c72bedece14b5797b1826e779c7fcb3e3024f820 Mon Sep 17 00:00:00 2001
+From: Jory Pratt <anarchy@gentoo.org>
+Date: Thu, 11 Jul 2019 14:19:30 -0500
+Subject: [PATCH] include missing stdint header
+
+Signed-off-by: Jory Pratt <anarchy@gentoo.org>
+Upstream-Status: Submitted
+---
+ ntreg.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/ntreg.h b/ntreg.h
+index 4b46106..d6fc7cf 100644
+--- a/ntreg.h
++++ b/ntreg.h
+@@ -24,6 +24,7 @@
+
+ #ifndef _INCLUDE_NTREG_H
+ #define _INCLUDE_NTREG_H 1
++#include <stdint.h>
+
+ #define SZ_MAX 4096 /* Max unicode strlen before we truncate */
+
+--
+2.22.0
+
diff --git a/app-crypt/chntpw/metadata.xml b/app-crypt/chntpw/metadata.xml
index 3e5026ee3754..beac02a9af14 100644
--- a/app-crypt/chntpw/metadata.xml
+++ b/app-crypt/chntpw/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>marecki@gentoo.org</email>