summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/codecrypt/codecrypt-1.8-r3.ebuild')
-rw-r--r--app-crypt/codecrypt/codecrypt-1.8-r3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-crypt/codecrypt/codecrypt-1.8-r3.ebuild b/app-crypt/codecrypt/codecrypt-1.8-r3.ebuild
new file mode 100644
index 000000000000..9c7a5e971a3c
--- /dev/null
+++ b/app-crypt/codecrypt/codecrypt-1.8-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Post-quantum cryptography tool"
+HOMEPAGE="http://e-x-a.org/codecrypt/"
+SRC_URI="http://e-x-a.org/codecrypt/files/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+cryptopp"
+
+DEPEND="
+ dev-libs/gmp:=
+ sci-libs/fftw:3.0=
+ cryptopp? ( >=dev-libs/crypto++-7:= )"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-libcryptopp.pc-rename.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with cryptopp)
+}