summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/codecrypt')
-rw-r--r--app-crypt/codecrypt/codecrypt-1.8-r3.ebuild (renamed from app-crypt/codecrypt/codecrypt-1.8-r2.ebuild)20
-rw-r--r--app-crypt/codecrypt/files/codecrypt-1.8-libcryptopp.pc-rename.patch13
-rw-r--r--app-crypt/codecrypt/metadata.xml3
3 files changed, 27 insertions, 9 deletions
diff --git a/app-crypt/codecrypt/codecrypt-1.8-r2.ebuild b/app-crypt/codecrypt/codecrypt-1.8-r3.ebuild
index d0a857db8986..9c7a5e971a3c 100644
--- a/app-crypt/codecrypt/codecrypt-1.8-r2.ebuild
+++ b/app-crypt/codecrypt/codecrypt-1.8-r3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools
@@ -14,18 +14,20 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="+cryptopp"
-DEPEND="dev-libs/gmp:=
- cryptopp? ( >=dev-libs/crypto++-7:= )
- sci-libs/fftw:3.0="
+DEPEND="
+ dev-libs/gmp:=
+ sci-libs/fftw:3.0=
+ cryptopp? ( >=dev-libs/crypto++-7:= )"
RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-libcryptopp.pc-rename.patch )
+
src_prepare() {
default
- # workaround -- the library renamed the pkg-config file
- sed -i -e 's/PKG_CHECK_MODULES(\[CRYPTOPP\],.*/PKG_CHECK_MODULES([CRYPTOPP], [libcryptopp])/' configure.ac || die
eautoreconf
}
src_configure() {
- econf \
- $(use_with cryptopp)
+ econf $(use_with cryptopp)
}
diff --git a/app-crypt/codecrypt/files/codecrypt-1.8-libcryptopp.pc-rename.patch b/app-crypt/codecrypt/files/codecrypt-1.8-libcryptopp.pc-rename.patch
new file mode 100644
index 000000000000..36cdf8bf4663
--- /dev/null
+++ b/app-crypt/codecrypt/files/codecrypt-1.8-libcryptopp.pc-rename.patch
@@ -0,0 +1,13 @@
+workaround -- the library renamed the pkg-config file
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -37,7 +37,7 @@
+
+ PKG_PROG_PKG_CONFIG([0.25])
+
+- PKG_CHECK_MODULES([CRYPTOPP],[libcrypto++])
++ PKG_CHECK_MODULES([CRYPTOPP],[libcryptopp])
+
+ #crypto++ headers are either in include/crypto++ or include/cryptopp,
+ #the information is otherwise unavailable from standard configuration
diff --git a/app-crypt/codecrypt/metadata.xml b/app-crypt/codecrypt/metadata.xml
index 29fad6b1698c..6b5e15c3f757 100644
--- a/app-crypt/codecrypt/metadata.xml
+++ b/app-crypt/codecrypt/metadata.xml
@@ -20,4 +20,7 @@
<use>
<flag name="cryptopp">Build algorithms that need Crypto++ support <pkg>dev-libs/crypto++</pkg></flag>
</use>
+ <upstream>
+ <remote-id type="github">exaexa/codecrypt</remote-id>
+ </upstream>
</pkgmetadata>