summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/coolkey')
-rw-r--r--app-crypt/coolkey/coolkey-1.1.0-r7.ebuild82
-rw-r--r--app-crypt/coolkey/coolkey-1.1.0-r9.ebuild3
-rw-r--r--app-crypt/coolkey/files/coolkey-1.1.0-clang16.patch13
3 files changed, 15 insertions, 83 deletions
diff --git a/app-crypt/coolkey/coolkey-1.1.0-r7.ebuild b/app-crypt/coolkey/coolkey-1.1.0-r7.ebuild
deleted file mode 100644
index 4a15201f3fba..000000000000
--- a/app-crypt/coolkey/coolkey-1.1.0-r7.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PATCHVER="003"
-
-DESCRIPTION="Linux Driver support for the CoolKey and CAC products"
-HOMEPAGE="https://directory.fedora.redhat.com/wiki/CoolKey"
-SRC_URI="https://directory.fedora.redhat.com/download/coolkey/${P}.tar.gz
- mirror://gentoo/${P}-patches-${PATCHVER}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="debug"
-
-RDEPEND=">=sys-apps/pcsc-lite-1.6.4
- dev-libs/nss[utils]
- sys-libs/zlib"
-DEPEND="${RDEPEND}
- >=app-crypt/ccid-1.4.0"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=(
- "${WORKDIR}/${PN}-patches"
-)
-
-pkg_setup() {
- pk="pk11install"
- dbdir="/etc/pki/nssdb"
- ck_mod_name="CoolKey PKCS #11 Module"
-
- if ! [[ -x $dbdir ]]; then
- ewarn "No /etc/pki/nssdb found; check under \$HOME/.pki and"
- ewarn "follow the suggested commands using the correct path."
- fi
-}
-
-src_configure() {
- econf \
- --enable-pk11install \
- $(use_enable debug)
-}
-
-src_compile() {
- emake CFLAGS+="-fno-strict-aliasing" -j1
-}
-
-src_install() {
- emake DESTDIR="${D}" install -j1
- einstalldocs
-}
-
-pkg_postinst() {
- if [[ -x $dbdir ]]; then
- if ! $(modutil -rawlist -dbdir $dbdir | grep libcoolkeypk11); then
- elog "You still need to install libcoolkey in your PKCS11 library:"
- elog "$pk -p $dbdir 'name=$ck_mod_name library=libcoolkeypk11.so'"
-
- fi
- else
- elog ""
- elog "You still need to setup your PKCS11 library, or at least"
- elog "find where it is (perhaps \$HOME/.pki/nssdb). Once you"
- elog "find it, use 'modutil -rawlist -dbdir \$db' to look for"
- elog "libcoolkeypk11.so, and if not found, add it using:"
- elog ""
- elog "$pk -p \$db 'name=$ck_mod_name library=libcoolkeypk11.so'"
- elog ""
- elog "where \$db is the full path to your pki/nssdb directory."
- elog ""
- fi
-}
-
-pkg_postrm() {
- if [[ -x $dbdir ]]; then
- if $(modutil -rawlist -dbdir $dbdir | grep libcoolkeypk11); then
- elog "You should remove libcoolkey from your PKCS11 library."
- fi
- fi
-}
diff --git a/app-crypt/coolkey/coolkey-1.1.0-r9.ebuild b/app-crypt/coolkey/coolkey-1.1.0-r9.ebuild
index cd3d7f1e434b..d388df3391b7 100644
--- a/app-crypt/coolkey/coolkey-1.1.0-r9.ebuild
+++ b/app-crypt/coolkey/coolkey-1.1.0-r9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -26,6 +26,7 @@ BDEPEND="virtual/pkgconfig"
PATCHES=(
"${WORKDIR}/${PN}-patches"
+ "${FILESDIR}/${P}-clang16.patch"
)
pkg_setup() {
diff --git a/app-crypt/coolkey/files/coolkey-1.1.0-clang16.patch b/app-crypt/coolkey/files/coolkey-1.1.0-clang16.patch
new file mode 100644
index 000000000000..88c3e11b53e8
--- /dev/null
+++ b/app-crypt/coolkey/files/coolkey-1.1.0-clang16.patch
@@ -0,0 +1,13 @@
+Declaration taken from nss sources' lib/softoken/pkcs11i.h.
+Only needed with --enable-pk11install.
+
+https://bugs.gentoo.org/871585
+--- a/src/install/pk11install.c
++++ b/src/install/pk11install.c
+@@ -23,4 +23,6 @@
+ #include "pkcs11n.h"
+
++char **NSC_ModuleDBFunc(unsigned long function, char *parameters, void *args);
++
+ /*
+ * windows specific globing search