summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/dehydrated')
-rw-r--r--app-crypt/dehydrated/Manifest2
-rw-r--r--app-crypt/dehydrated/dehydrated-0.7.0-r1.ebuild (renamed from app-crypt/dehydrated/dehydrated-0.7.0.ebuild)10
-rw-r--r--app-crypt/dehydrated/dehydrated-0.7.1.ebuild61
-rw-r--r--app-crypt/dehydrated/files/00_gentoo.sh-r14
-rw-r--r--app-crypt/dehydrated/files/cron2
-rw-r--r--app-crypt/dehydrated/files/cron-r12
-rw-r--r--app-crypt/dehydrated/metadata.xml4
7 files changed, 74 insertions, 11 deletions
diff --git a/app-crypt/dehydrated/Manifest b/app-crypt/dehydrated/Manifest
index a30f779bfc96..a35814a589cb 100644
--- a/app-crypt/dehydrated/Manifest
+++ b/app-crypt/dehydrated/Manifest
@@ -1 +1,3 @@
DIST dehydrated-0.7.0.tar.gz 86574 BLAKE2B 35a3b0b7592126ca65003a6c9eb8934a76584710d028057e5add7f77bb2fa3799e89a060306da3b98a62d291229a2a78f23e0f95f19e033796aee31e97b94488 SHA512 47740d2d31ca73482a4fc5ed0dfce986af907dd5449cb3a5230bf9683845686c8122fc32e6219a4439574ef11d6fb104ee09591c5ff667927a2c9c13ba005511
+DIST dehydrated-0.7.1.tar.gz 119992 BLAKE2B 0b287537206936ceff33bde8bbb8ab7b13f28bf58cd29c898348db0cf5a83157fed4535da218ac48a810a93b99474e96334a27c062c157e2f164b0e516b47111 SHA512 b7ac078d6034e784f3f485e8ce56b5fa2f1e2a3b5ef014d260046b5f1d5cbd99727501e95a9530d0d1b2f300003d3fa5bf7e7f532092041597236d92fbeb0f3c
+DIST dehydrated-0.7.1.tar.gz.asc 488 BLAKE2B 0dd678976f897e8684695bce1742e498bcbec0f78781a53dae7f715a1a379f85eba3531c0f3181dcab9bd7005f086e82889dad6d26f7d2075c877eef3d653acf SHA512 f03872b7e087b3f719a76aaebd46f017f47595feb03a29f5fcbe33796655cdcd0a34580ae34a85e3280c8305a2fe2ada47e4436bfbec294b7dbf67768df86394
diff --git a/app-crypt/dehydrated/dehydrated-0.7.0.ebuild b/app-crypt/dehydrated/dehydrated-0.7.0-r1.ebuild
index 471ea8763971..120ac925e81f 100644
--- a/app-crypt/dehydrated/dehydrated-0.7.0.ebuild
+++ b/app-crypt/dehydrated/dehydrated-0.7.0-r1.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
DESCRIPTION="A client for signing certificates with an ACME-server"
-HOMEPAGE="https://github.com/lukas2511/dehydrated"
-SRC_URI="https://github.com/lukas2511/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/dehydrated-io/dehydrated"
+SRC_URI="https://github.com/dehydrated-io/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 arm arm64 ~riscv x86"
+KEYWORDS="amd64 arm arm64 ~ppc64 ~riscv x86"
IUSE="+cron"
RDEPEND="acct-group/dehydrated
@@ -37,7 +37,7 @@ src_install() {
if use cron ; then
insinto /etc/cron.d
- newins "${FILESDIR}"/cron ${PN}
+ newins "${FILESDIR}"/cron-r1 ${PN}
fi
}
diff --git a/app-crypt/dehydrated/dehydrated-0.7.1.ebuild b/app-crypt/dehydrated/dehydrated-0.7.1.ebuild
new file mode 100644
index 000000000000..c760e927efba
--- /dev/null
+++ b/app-crypt/dehydrated/dehydrated-0.7.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/dehydrated.asc
+
+inherit verify-sig
+
+DESCRIPTION="A client for signing certificates with an ACME-server"
+HOMEPAGE="https://dehydrated.io/"
+SRC_URI="
+ https://github.com/dehydrated-io/${PN}/releases/download/v${PV}/${P}.tar.gz
+ verify-sig? ( https://github.com/dehydrated-io/${PN}/releases/download/v${PV}/${P}.tar.gz.asc )
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="+cron"
+
+BDEPEND="verify-sig? ( sec-keys/openpgp-keys-dehydrated )"
+RDEPEND="acct-group/dehydrated
+ acct-user/dehydrated
+ app-shells/bash
+ net-misc/curl
+ cron? ( virtual/cron )"
+
+src_configure() {
+ default
+ sed -i 's,^#CONFIG_D=.*,CONFIG_D="/etc/dehydrated/config.d",' docs/examples/config \
+ || die "could not set config (CONFIG_D)"
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /etc/${PN}
+ doins docs/examples/{config,domains.txt,hook.sh}
+ fperms u+x /etc/${PN}/hook.sh
+ dodoc docs/*.md
+
+ insinto /etc/${PN}/config.d
+ newins "${FILESDIR}"/00_gentoo.sh-r1 00_gentoo.sh
+
+ keepdir /etc/${PN}/domains.d
+
+ doman docs/man/dehydrated.1
+
+ if use cron ; then
+ insinto /etc/cron.d
+ newins "${FILESDIR}"/cron-r1 ${PN}
+ fi
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]] ; then
+ einfo "See /etc/dehydrated/config for configuration."
+
+ use cron && einfo "After finishing setup you should enable the cronjob in /etc/cron.d/dehydrated."
+ fi
+}
diff --git a/app-crypt/dehydrated/files/00_gentoo.sh-r1 b/app-crypt/dehydrated/files/00_gentoo.sh-r1
new file mode 100644
index 000000000000..53e9c0dfe538
--- /dev/null
+++ b/app-crypt/dehydrated/files/00_gentoo.sh-r1
@@ -0,0 +1,4 @@
+# base config required for gentoo defaults
+BASEDIR="/var/lib/dehydrated"
+DOMAINS_TXT="/etc/dehydrated/domains.txt"
+DOMAINS_D="/etc/dehydrated/domains.d"
diff --git a/app-crypt/dehydrated/files/cron b/app-crypt/dehydrated/files/cron
deleted file mode 100644
index df03b5fcee13..000000000000
--- a/app-crypt/dehydrated/files/cron
+++ /dev/null
@@ -1,2 +0,0 @@
-# dehydrated cron job
-#0 2 * * * dehydrated /usr/bin/dehydrated --cron
diff --git a/app-crypt/dehydrated/files/cron-r1 b/app-crypt/dehydrated/files/cron-r1
new file mode 100644
index 000000000000..31d1bb805a3e
--- /dev/null
+++ b/app-crypt/dehydrated/files/cron-r1
@@ -0,0 +1,2 @@
+# dehydrated cron job
+#27 2 * * * dehydrated /usr/bin/dehydrated --cron
diff --git a/app-crypt/dehydrated/metadata.xml b/app-crypt/dehydrated/metadata.xml
index 01e9074304e2..d4974e2fd2d8 100644
--- a/app-crypt/dehydrated/metadata.xml
+++ b/app-crypt/dehydrated/metadata.xml
@@ -4,10 +4,6 @@
<maintainer type="person">
<email>mschiff@gentoo.org</email>
</maintainer>
- <maintainer type="person">
- <email>whissi@gentoo.org</email>
- <name>Thomas Deutschmann</name>
- </maintainer>
<stabilize-allarches/>
<use>
<flag name="cron">Install cron job to sign/renew non-existent/changed/expiring certificates</flag>