summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/gpgme')
-rw-r--r--app-crypt/gpgme/Manifest5
-rw-r--r--app-crypt/gpgme/files/gpgme-1.18.0-tests-start-stop-agent-use-command-v.patch27
-rw-r--r--app-crypt/gpgme/files/gpgme-1.23.1-tests-gnupg-no-tofu.patch26
-rw-r--r--app-crypt/gpgme/gpgme-1.14.0.ebuild110
-rw-r--r--app-crypt/gpgme/gpgme-1.15.0.ebuild110
-rw-r--r--app-crypt/gpgme/gpgme-1.15.1.ebuild110
-rw-r--r--app-crypt/gpgme/gpgme-1.23.2.ebuild227
-rw-r--r--app-crypt/gpgme/metadata.xml8
8 files changed, 286 insertions, 337 deletions
diff --git a/app-crypt/gpgme/Manifest b/app-crypt/gpgme/Manifest
index 48746098dd14..dc87e8b9a1dc 100644
--- a/app-crypt/gpgme/Manifest
+++ b/app-crypt/gpgme/Manifest
@@ -1,3 +1,2 @@
-DIST gpgme-1.14.0.tar.bz2 1678910 BLAKE2B 75051166b1f3777d630236c5afbd1786df238272b7ccfd053c5a4b2a207ba146550f6be46c1211f3bacbe19fee2f67adbc5be558d69175c19230a1a02e32d9f2 SHA512 b7ffa30a046c75215e1c73e2f34e5e65532e4dcf6bea55796adc6f82fd38dafe264bcd4332b2001155d6f9476d6fd82a77112dad31c1bb29db9ddefc532ae668
-DIST gpgme-1.15.0.tar.bz2 1692019 BLAKE2B 4c66f24034a88e7da8a06cef3d0ac9d1d6b5eccb6d4277d36a2399d6e78f5d5f42cf0c13188c1dba72fe11d73da76a71867d3c3b13052695b868dc4a680fa85b SHA512 ab979aea6ccc6d4faf02b3b1a773ce95cb754b4d687ce7adc2ed98e218f21a284a2283d8e2429016e78fcf5a94ea863011573fd1457a71cc0ae3aadd368a98a1
-DIST gpgme-1.15.1.tar.bz2 1699349 BLAKE2B d3a6ccaa35360ed3fc79364dfcc3f2fdcb70e5e41ac72ef011373a39d5def9be9ce1be45843ab65a87630d3fc570d29db5f40b9a273aa8e281464c9d1d3477de SHA512 1d75a848cce6389f7cb8896b57a28dfe1dc5a447bfb4f128b0994a43e04134343400a3be063e971f03dfd595474cfd558519741d5d56afb3e84853ad4f2a45c2
+DIST gpgme-1.23.2.tar.bz2 1836904 BLAKE2B 563e470e861c7cc64ecb3e8dd0a0ed8436bc0867105093abcec09f4d1e1dd95cbf64c8161cf8500b9842583b57f6583efff63e5111234e36fda1e6fbedce2f78 SHA512 6cfcd07e81a93de240582de5a46545420cee93d1f27fe20ea2c983780fdd3036b69fdba073cf549d68a20791e189bf4b3cdde14a43f912d2ab9ef3414c83ac75
+DIST gpgme-1.23.2.tar.bz2.sig 238 BLAKE2B fafba6e2f1f34c53fa3f7e05953298132f7b046048660b9f2df5bc11ccb9694b581117ca78883a8f4ca9af060397a39f3132a3711be1cd28183b7c2f8f93a8b7 SHA512 65b7cdd4ce06bb0b15b13033d226423380338efdcb47ffc3f33780a92973453053f8f59b12a3f37e392e773bdd207a7420c25aa3a210c15eec45b7bfef6e891e
diff --git a/app-crypt/gpgme/files/gpgme-1.18.0-tests-start-stop-agent-use-command-v.patch b/app-crypt/gpgme/files/gpgme-1.18.0-tests-start-stop-agent-use-command-v.patch
new file mode 100644
index 000000000000..aeae35f45636
--- /dev/null
+++ b/app-crypt/gpgme/files/gpgme-1.18.0-tests-start-stop-agent-use-command-v.patch
@@ -0,0 +1,27 @@
+Sent upstream to gnupg-devel@ but not yet in archive.
+
+From: Sam James <sam@gentoo.org>
+Date: Mon, 15 Aug 2022 19:29:06 +0100
+Subject: [PATCH] tests/start-stop-agent: use 'command -v' instead of 'which'
+
+`which` is an external command which isn't required by POSIX.
+
+Debian and other distributions (like Gentoo!) are looking
+to drop it from their base set of packages.
+
+Switch to `command -v` which should always work instead.
+
+Note we already use `command -v` at the start of this test anyway.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/tests/start-stop-agent
++++ b/tests/start-stop-agent
+@@ -15,7 +15,7 @@ fi
+
+ GPG_AGENT_INFO=
+ export GPG_AGENT_INFO
+-GPG_AGENT=$(which gpg-agent)
++GPG_AGENT=$(command -v gpg-agent)
+
+ token=$(echo "gpgme-$(pwd)" | tr ' ' '_')
+
diff --git a/app-crypt/gpgme/files/gpgme-1.23.1-tests-gnupg-no-tofu.patch b/app-crypt/gpgme/files/gpgme-1.23.1-tests-gnupg-no-tofu.patch
new file mode 100644
index 000000000000..831f68c8ea18
--- /dev/null
+++ b/app-crypt/gpgme/files/gpgme-1.23.1-tests-gnupg-no-tofu.patch
@@ -0,0 +1,26 @@
+https://dev.gnupg.org/T6778
+--- a/lang/python/tests/support.py
++++ b/lang/python/tests/support.py
+@@ -46,13 +46,15 @@ def is_gpg_version(version):
+
+
+ def have_tofu_support(ctx, some_uid):
+- keys = list(
+- ctx.keylist(
+- some_uid,
+- mode=(gpg.constants.keylist.mode.LOCAL |
+- gpg.constants.keylist.mode.WITH_TOFU)))
+- return len(keys) > 0
+-
++ try:
++ keys = list(
++ ctx.keylist(
++ some_uid,
++ mode=(gpg.constants.keylist.mode.LOCAL |
++ gpg.constants.keylist.mode.WITH_TOFU)))
++ return len(keys) > 0
++ except gpg.errors.GPGMEError:
++ return False
+
+ # Skip the Python tests for GnuPG < 2.1.12. Prior versions do not
+ # understand the command line flags that we assume exist. C.f. issue
diff --git a/app-crypt/gpgme/gpgme-1.14.0.ebuild b/app-crypt/gpgme/gpgme-1.14.0.ebuild
deleted file mode 100644
index 5bc323ad0812..000000000000
--- a/app-crypt/gpgme/gpgme-1.14.0.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_OPTIONAL=1
-
-inherit distutils-r1 flag-o-matic libtool qmake-utils toolchain-funcs
-
-DESCRIPTION="GnuPG Made Easy is a library for making GnuPG easier to use"
-HOMEPAGE="http://www.gnupg.org/related_software/gpgme"
-SRC_URI="mirror://gnupg/gpgme/${P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="1/11" # subslot = soname major version
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="common-lisp static-libs +cxx python qt5"
-
-RDEPEND=">=app-crypt/gnupg-2
- >=dev-libs/libassuan-2.5.3:=
- >=dev-libs/libgpg-error-1.29:=
- python? ( ${PYTHON_DEPS} )
- qt5? ( dev-qt/qtcore:5 )"
- #doc? ( app-doc/doxygen[dot] )
-DEPEND="${RDEPEND}
- qt5? ( dev-qt/qttest:5 )"
-BDEPEND="python? ( dev-lang/swig )"
-
-REQUIRED_USE="qt5? ( cxx ) python? ( ${PYTHON_REQUIRED_USE} )"
-
-do_python() {
- if use python; then
- pushd "lang/python" > /dev/null || die
- top_builddir="../.." srcdir="." CPP=$(tc-getCPP) distutils-r1_src_${EBUILD_PHASE}
- popd > /dev/null
- fi
-}
-
-pkg_setup() {
- addpredict /run/user/$(id -u)/gnupg
-
- local MAX_WORKDIR=66
- if [[ "${#WORKDIR}" -gt "${MAX_WORKDIR}" ]]; then
- ewarn "Disabling tests as WORKDIR '${WORKDIR}' is longer than ${MAX_WORKDIR} which will fail tests"
- SKIP_TESTS=1
- fi
-}
-
-src_prepare() {
- default
- elibtoolize
-
- # Make best effort to allow longer PORTAGE_TMPDIR
- # as usock limitation fails build/tests
- ln -s "${P}" "${WORKDIR}/b"
- S="${WORKDIR}/b"
-}
-
-src_configure() {
- local languages=()
- use common-lisp && languages+=( "cl" )
- use cxx && languages+=( "cpp" )
- if use qt5; then
- languages+=( "qt" )
- #use doc ||
- export DOXYGEN=true
- export MOC="$(qt5_get_bindir)/moc"
- fi
-
- econf \
- $([[ -n "${SKIP_TESTS}" ]] && echo "--disable-gpg-test --disable-gpgsm-test") \
- --enable-languages="${languages[*]}" \
- $(use_enable static-libs static)
-
- use python && make -C lang/python prepare
-
- do_python
-}
-
-src_compile() {
- default
- do_python
-}
-
-src_test() {
- [[ -z "${SKIP_TESTS}" ]] || return
-
- default
- if use python; then
- test_python() {
- emake -C lang/python/tests check \
- PYTHON=${EPYTHON} \
- PYTHONS=${EPYTHON} \
- TESTFLAGS="--python-libdir=${BUILD_DIR}/lib"
- }
- python_foreach_impl test_python
- fi
-}
-
-src_install() {
- default
- do_python
- find "${ED}" -type f -name '*.la' -delete || die
-
- # backward compatibility for gentoo
- # in the past we had slots
- dodir /usr/include/gpgme
- dosym ../gpgme.h /usr/include/gpgme/gpgme.h
-}
diff --git a/app-crypt/gpgme/gpgme-1.15.0.ebuild b/app-crypt/gpgme/gpgme-1.15.0.ebuild
deleted file mode 100644
index c87f99a58840..000000000000
--- a/app-crypt/gpgme/gpgme-1.15.0.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_OPTIONAL=1
-
-inherit distutils-r1 flag-o-matic libtool qmake-utils toolchain-funcs
-
-DESCRIPTION="GnuPG Made Easy is a library for making GnuPG easier to use"
-HOMEPAGE="http://www.gnupg.org/related_software/gpgme"
-SRC_URI="mirror://gnupg/gpgme/${P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="1/11" # subslot = soname major version
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="common-lisp static-libs +cxx python qt5"
-
-RDEPEND=">=app-crypt/gnupg-2
- >=dev-libs/libassuan-2.5.3:=
- >=dev-libs/libgpg-error-1.36:=
- python? ( ${PYTHON_DEPS} )
- qt5? ( dev-qt/qtcore:5 )"
- #doc? ( app-doc/doxygen[dot] )
-DEPEND="${RDEPEND}
- qt5? ( dev-qt/qttest:5 )"
-BDEPEND="python? ( dev-lang/swig )"
-
-REQUIRED_USE="qt5? ( cxx ) python? ( ${PYTHON_REQUIRED_USE} )"
-
-do_python() {
- if use python; then
- pushd "lang/python" > /dev/null || die
- top_builddir="../.." srcdir="." CPP=$(tc-getCPP) distutils-r1_src_${EBUILD_PHASE}
- popd > /dev/null
- fi
-}
-
-pkg_setup() {
- addpredict /run/user/$(id -u)/gnupg
-
- local MAX_WORKDIR=66
- if [[ "${#WORKDIR}" -gt "${MAX_WORKDIR}" ]]; then
- ewarn "Disabling tests as WORKDIR '${WORKDIR}' is longer than ${MAX_WORKDIR} which will fail tests"
- SKIP_TESTS=1
- fi
-}
-
-src_prepare() {
- default
- elibtoolize
-
- # Make best effort to allow longer PORTAGE_TMPDIR
- # as usock limitation fails build/tests
- ln -s "${P}" "${WORKDIR}/b"
- S="${WORKDIR}/b"
-}
-
-src_configure() {
- local languages=()
- use common-lisp && languages+=( "cl" )
- use cxx && languages+=( "cpp" )
- if use qt5; then
- languages+=( "qt" )
- #use doc ||
- export DOXYGEN=true
- export MOC="$(qt5_get_bindir)/moc"
- fi
-
- econf \
- $([[ -n "${SKIP_TESTS}" ]] && echo "--disable-gpg-test --disable-gpgsm-test") \
- --enable-languages="${languages[*]}" \
- $(use_enable static-libs static)
-
- use python && make -C lang/python prepare
-
- do_python
-}
-
-src_compile() {
- default
- do_python
-}
-
-src_test() {
- [[ -z "${SKIP_TESTS}" ]] || return
-
- default
- if use python; then
- test_python() {
- emake -C lang/python/tests check \
- PYTHON=${EPYTHON} \
- PYTHONS=${EPYTHON} \
- TESTFLAGS="--python-libdir=${BUILD_DIR}/lib"
- }
- python_foreach_impl test_python
- fi
-}
-
-src_install() {
- default
- do_python
- find "${ED}" -type f -name '*.la' -delete || die
-
- # backward compatibility for gentoo
- # in the past we had slots
- dodir /usr/include/gpgme
- dosym ../gpgme.h /usr/include/gpgme/gpgme.h
-}
diff --git a/app-crypt/gpgme/gpgme-1.15.1.ebuild b/app-crypt/gpgme/gpgme-1.15.1.ebuild
deleted file mode 100644
index 3e89833a85e6..000000000000
--- a/app-crypt/gpgme/gpgme-1.15.1.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_OPTIONAL=1
-
-inherit distutils-r1 flag-o-matic libtool qmake-utils toolchain-funcs
-
-DESCRIPTION="GnuPG Made Easy is a library for making GnuPG easier to use"
-HOMEPAGE="http://www.gnupg.org/related_software/gpgme"
-SRC_URI="mirror://gnupg/gpgme/${P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="1/11" # subslot = soname major version
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="common-lisp static-libs +cxx python qt5"
-
-RDEPEND=">=app-crypt/gnupg-2
- >=dev-libs/libassuan-2.5.3:=
- >=dev-libs/libgpg-error-1.36:=
- python? ( ${PYTHON_DEPS} )
- qt5? ( dev-qt/qtcore:5 )"
- #doc? ( app-doc/doxygen[dot] )
-DEPEND="${RDEPEND}
- qt5? ( dev-qt/qttest:5 )"
-BDEPEND="python? ( dev-lang/swig )"
-
-REQUIRED_USE="qt5? ( cxx ) python? ( ${PYTHON_REQUIRED_USE} )"
-
-do_python() {
- if use python; then
- pushd "lang/python" > /dev/null || die
- top_builddir="../.." srcdir="." CPP=$(tc-getCPP) distutils-r1_src_${EBUILD_PHASE}
- popd > /dev/null
- fi
-}
-
-pkg_setup() {
- addpredict /run/user/$(id -u)/gnupg
-
- local MAX_WORKDIR=66
- if [[ "${#WORKDIR}" -gt "${MAX_WORKDIR}" ]]; then
- ewarn "Disabling tests as WORKDIR '${WORKDIR}' is longer than ${MAX_WORKDIR} which will fail tests"
- SKIP_TESTS=1
- fi
-}
-
-src_prepare() {
- default
- elibtoolize
-
- # Make best effort to allow longer PORTAGE_TMPDIR
- # as usock limitation fails build/tests
- ln -s "${P}" "${WORKDIR}/b"
- S="${WORKDIR}/b"
-}
-
-src_configure() {
- local languages=()
- use common-lisp && languages+=( "cl" )
- use cxx && languages+=( "cpp" )
- if use qt5; then
- languages+=( "qt" )
- #use doc ||
- export DOXYGEN=true
- export MOC="$(qt5_get_bindir)/moc"
- fi
-
- econf \
- $([[ -n "${SKIP_TESTS}" ]] && echo "--disable-gpg-test --disable-gpgsm-test") \
- --enable-languages="${languages[*]}" \
- $(use_enable static-libs static)
-
- use python && make -C lang/python prepare
-
- do_python
-}
-
-src_compile() {
- default
- do_python
-}
-
-src_test() {
- [[ -z "${SKIP_TESTS}" ]] || return
-
- default
- if use python; then
- test_python() {
- emake -C lang/python/tests check \
- PYTHON=${EPYTHON} \
- PYTHONS=${EPYTHON} \
- TESTFLAGS="--python-libdir=${BUILD_DIR}/lib"
- }
- python_foreach_impl test_python
- fi
-}
-
-src_install() {
- default
- do_python
- find "${ED}" -type f -name '*.la' -delete || die
-
- # backward compatibility for gentoo
- # in the past we had slots
- dodir /usr/include/gpgme
- dosym ../gpgme.h /usr/include/gpgme/gpgme.h
-}
diff --git a/app-crypt/gpgme/gpgme-1.23.2.ebuild b/app-crypt/gpgme/gpgme-1.23.2.ebuild
new file mode 100644
index 000000000000..933a0672a758
--- /dev/null
+++ b/app-crypt/gpgme/gpgme-1.23.2.ebuild
@@ -0,0 +1,227 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Maintainers should:
+# 1. Join the "Gentoo" project at https://dev.gnupg.org/project/view/27/
+# 2. Subscribe to release tasks like https://dev.gnupg.org/T6159
+# (find the one for the current release then subscribe to it +
+# any subsequent ones linked within so you're covered for a while.)
+
+DISTUTILS_EXT=1
+DISTUTILS_OPTIONAL=1
+PYTHON_COMPAT=( python3_{10..12} )
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/gnupg.asc
+
+# in-source builds are not supported:
+# * https://dev.gnupg.org/T6313#166339
+# * https://dev.gnupg.org/T6673#174545
+inherit distutils-r1 libtool flag-o-matic multibuild qmake-utils toolchain-funcs verify-sig
+
+DESCRIPTION="GnuPG Made Easy is a library for making GnuPG easier to use"
+HOMEPAGE="https://www.gnupg.org/related_software/gpgme"
+SRC_URI="
+ mirror://gnupg/gpgme/${P}.tar.bz2
+ verify-sig? ( mirror://gnupg/gpgme/${P}.tar.bz2.sig )
+"
+
+LICENSE="GPL-2 LGPL-2.1"
+# Please check ABI on each bump, even if SONAMEs didn't change: bug #833355
+# Use e.g. app-portage/iwdevtools integration with dev-libs/libabigail's abidiff.
+# Subslot: SONAME of each: <libgpgme.libgpgmepp.libqgpgme.FUDGE>
+# Bump FUDGE if a release is made which breaks ABI without changing SONAME.
+# (Reset to 0 if FUDGE != 0 if libgpgme/libgpgmepp/libqpggme change.)
+SLOT="1/11.6.15.2"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="common-lisp static-libs +cxx python qt5 qt6 test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="
+ qt5? ( cxx )
+ qt6? ( cxx )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+# - On each bump, update dep bounds on each version from configure.ac!
+RDEPEND="
+ >=app-crypt/gnupg-2
+ >=dev-libs/libassuan-2.5.3:=
+ >=dev-libs/libgpg-error-1.46-r1:=
+ python? ( ${PYTHON_DEPS} )
+ qt5? ( dev-qt/qtcore:5 )
+ qt6? ( dev-qt/qtbase:6 )
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ qt5? ( dev-qt/qttest:5 )
+ )
+"
+#doc? ( app-text/doxygen[dot] )
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ' python3_12)
+ python? ( dev-lang/swig )
+ verify-sig? ( sec-keys/openpgp-keys-gnupg )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.18.0-tests-start-stop-agent-use-command-v.patch
+ "${FILESDIR}"/${PN}-1.23.1-tests-gnupg-no-tofu.patch
+)
+
+src_prepare() {
+ default
+
+ elibtoolize
+
+ # bug #697456
+ addpredict /run/user/$(id -u)/gnupg
+
+ local MAX_WORKDIR=66
+ if use test && [[ "${#WORKDIR}" -gt "${MAX_WORKDIR}" ]]; then
+ eerror "Unable to run tests as WORKDIR='${WORKDIR}' is longer than ${MAX_WORKDIR} which causes failure!"
+ die "Could not run tests as requested with too-long WORKDIR."
+ fi
+
+ # Make best effort to allow longer PORTAGE_TMPDIR
+ # as usock limitation fails build/tests
+ ln -s "${P}" "${WORKDIR}/b" || die
+ S="${WORKDIR}/b"
+
+ # Qt 5 and Qt 6 are mutually exclusive in the gpgme build. We don't have
+ # to do three builds (normal, qt5, qt6), and we can instead just
+ # do normal+qt5 or normal+qt6. For now, we pessimise qt6 by making it
+ # be a separate build, but in time, we can swap it so qt5 has to be
+ # the separate one so some build time gets saved in the common case.
+ MULTIBUILD_VARIANTS=(
+ base
+ $(usev qt6 qt6)
+ )
+
+ gpgme_create_builddir() {
+ mkdir -p "${BUILD_DIR}" || die
+ }
+
+ multibuild_foreach_variant gpgme_create_builddir
+}
+
+src_configure() {
+ multibuild_foreach_variant gpgme_src_configure
+}
+
+gpgme_src_configure() {
+ # bug #847955
+ append-lfs-flags
+
+ cd "${BUILD_DIR}" || die
+
+ local languages=()
+
+ case ${MULTIBUILD_VARIANT} in
+ base)
+ languages=(
+ $(usev common-lisp 'cl')
+ $(usev cxx 'cpp')
+ $(usev qt5 'qt5')
+ )
+
+ if use qt5; then
+ #use doc ||
+ export DOXYGEN=true
+ export MOC="$(qt5_get_bindir)/moc"
+ fi
+
+ ;;
+ *)
+ # Sanity check for refactoring, the non-base variant is only for Qt 6
+ use qt6 || die "Non-base variant shouldn't be built without Qt 6! Please report at bugs.gentoo.org."
+
+ languages=(
+ cpp
+ qt6
+ )
+
+ export MOC="$(qt6_get_libdir)/qt6/libexec/moc"
+
+ ;;
+ esac
+
+ local myeconfargs=(
+ $(use test || echo "--disable-gpgconf-test --disable-gpg-test --disable-gpgsm-test --disable-g13-test")
+ --enable-languages="${languages[*]}"
+ $(use_enable static-libs static)
+ )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+
+ if [[ ${MULTIBUILD_VARIANT} == base ]] && use python ; then
+ emake -C lang/python prepare
+
+ pushd lang/python > /dev/null || die
+ top_builddir="../.." srcdir="${S}/lang/python" CPP="$(tc-getCPP)" distutils-r1_src_configure
+ popd > /dev/null || die
+ fi
+}
+
+src_compile() {
+ multibuild_foreach_variant gpgme_src_compile
+}
+
+gpgme_src_compile() {
+ cd "${BUILD_DIR}" || die
+
+ emake
+
+ if [[ ${MULTIBUILD_VARIANT} == base ]] && use python ; then
+ pushd lang/python > /dev/null || die
+ top_builddir="../.." srcdir="${S}/lang/python" CPP="$(tc-getCPP)" distutils-r1_src_compile
+ popd > /dev/null || die
+ fi
+}
+
+src_test() {
+ multibuild_foreach_variant gpgme_src_test
+}
+
+gpgme_src_test() {
+ cd "${BUILD_DIR}" || die
+
+ emake check
+
+ if [[ ${MULTIBUILD_VARIANT} == base ]] && use python ; then
+ distutils-r1_src_test
+ fi
+}
+
+python_test() {
+ emake -C lang/python/tests check \
+ PYTHON=${EPYTHON} \
+ PYTHONS=${EPYTHON} \
+ TESTFLAGS="--python-libdir=${BUILD_DIR}/lib"
+}
+
+src_install() {
+ einstalldocs
+ multibuild_foreach_variant gpgme_src_install
+}
+
+gpgme_src_install() {
+ cd "${BUILD_DIR}" || die
+
+ emake DESTDIR="${D}" install
+
+ if [[ ${MULTIBUILD_VARIANT} == base ]] && use python ; then
+ pushd lang/python > /dev/null || die
+ top_builddir="../.." srcdir="${S}/lang/python" CPP="$(tc-getCPP)" distutils-r1_src_install
+ popd > /dev/null || die
+ fi
+
+ find "${ED}" -type f -name '*.la' -delete || die
+
+ # Backward compatibility for gentoo
+ # (in the past, we had slots)
+ dodir /usr/include/gpgme
+ dosym -r /usr/include/gpgme.h /usr/include/gpgme/gpgme.h
+}
diff --git a/app-crypt/gpgme/metadata.xml b/app-crypt/gpgme/metadata.xml
index 3ba821be5c34..12645d415e43 100644
--- a/app-crypt/gpgme/metadata.xml
+++ b/app-crypt/gpgme/metadata.xml
@@ -1,9 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <name>Lars Wendler</name>
- <email>polynomial-c@gentoo.org</email>
+ <maintainer type="project">
+ <email>base-system@gentoo.org</email>
+ <name>Gentoo Base System</name>
</maintainer>
<use>
<flag name="common-lisp">Install common-lisp files</flag>