summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/johntheripper-jumbo/johntheripper-jumbo-9999.ebuild')
-rw-r--r--app-crypt/johntheripper-jumbo/johntheripper-jumbo-9999.ebuild52
1 files changed, 28 insertions, 24 deletions
diff --git a/app-crypt/johntheripper-jumbo/johntheripper-jumbo-9999.ebuild b/app-crypt/johntheripper-jumbo/johntheripper-jumbo-9999.ebuild
index d1fbfc6ec025..d4b9287e610c 100644
--- a/app-crypt/johntheripper-jumbo/johntheripper-jumbo-9999.ebuild
+++ b/app-crypt/johntheripper-jumbo/johntheripper-jumbo-9999.ebuild
@@ -1,28 +1,22 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools flag-o-matic toolchain-funcs pax-utils
-DESCRIPTION="Fast password cracker"
+DESCRIPTION="Fast password cracker, community enhanced version"
HOMEPAGE="http://www.openwall.com/john/"
-MY_PN="JohnTheRipper"
-
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/magnumripper/${MY_PN}.git"
+ EGIT_REPO_URI="https://github.com/openwall/john.git"
+ EGIT_BRANCH="bleeding-jumbo"
inherit git-r3
else
- JUMBO="jumbo-1.1"
- MY_PV="${PV}-${JUMBO}"
- MY_P="john-${MY_PV}"
- HASH_COMMIT="5d0c85f16f96ca7b6dd06640e95a5801081d6e20"
-
+ HASH_COMMIT="9daf16b5743b2c521d23c281e13ae8cdbd37b1eb"
SRC_URI="https://github.com/openwall/john/archive/${HASH_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/john-${HASH_COMMIT}"
-
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
fi
LICENSE="GPL-2"
@@ -43,16 +37,20 @@ DEPEND=">=dev-libs/openssl-1.0.1:=
# - Digest::x
# See bug #777369.
RDEPEND="${DEPEND}
+ dev-perl/Compress-Raw-Lzma
dev-perl/Digest-MD2
virtual/perl-Digest-MD5
dev-perl/Digest-SHA3
dev-perl/Digest-GOST
!app-crypt/johntheripper"
+RESTRICT="test"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
pkg_setup() {
- if use openmp && [[ ${MERGE_TYPE} != binary ]]; then
- tc-has-openmp || die "Please switch to an OpenMP compatible compiler"
- fi
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_prepare() {
@@ -85,24 +83,28 @@ src_configure() {
src_compile() {
# Uses default LD=$(CC) but if the user's set LD, it'll call it
# bug #729432.
- emake LD=$(tc-getCC) -C src
+ emake LD="$(tc-getCC)" -C src
}
src_test() {
pax-mark -mr run/john
- #if use opencl; then
+ # this probably causes the following failure:
+ # Testing: as400-des, AS/400 DES [DES 32/64]... PASS
+ # Error, Invalid signature line trying to link to dynamic format.
+ # Original format=as400-ssha1
+ sed '/.include /d' run/john.conf > run/john-test.conf
+ if use opencl; then
# GPU tests fail in portage, so run cpu only tests
- # ./run/john --device=cpu --test=0 --verbosity=2 || die
- #else
+ ./run/john --config=run/john-test.conf --device=cpu --test=0 --verbosity=2 || die
+ else
# Weak tests
- #./run/john --test=0 --verbosity=2 || die
+ ./run/john --config=run/john-test.conf --test=0 --verbosity=2 || die
# Strong tests
#./run/john --test=1 --verbosity=2 || die
- #fi
+ fi
- ewarn "When built systemwide, john can't run tests without reading files in /etc."
- ewarn "Don't bother opening a bug for this unless you include a patch to fix it"
+ rm john-test.conf || die
}
src_install() {
@@ -126,6 +128,8 @@ src_install() {
exeinto /usr/share/john
doexe run/*.pl
doexe run/*.py
+ insinto /usr/share/john
+ doins -r run/lib
cd run || die
local s