summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/letsencrypt/letsencrypt-0.1.1-r1.ebuild')
-rw-r--r--app-crypt/letsencrypt/letsencrypt-0.1.1-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-crypt/letsencrypt/letsencrypt-0.1.1-r1.ebuild b/app-crypt/letsencrypt/letsencrypt-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..76472f336e9e
--- /dev/null
+++ b/app-crypt/letsencrypt/letsencrypt-0.1.1-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python2_7)
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/letsencrypt/letsencrypt.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}-corrected.tar.gz -> ${P}-corrected.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="https://github.com/letsencrypt/letsencrypt https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ dev-python/configargparse[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-0.7[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/parsedatetime[${PYTHON_USEDEP}]
+ >=dev-python/psutil-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.15[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ >=dev-python/pythondialog-3.2.2:python-2[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${P}-corrected
+
+python_test() {
+ nosetests -w ${PN}/tests || die
+}