summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/libmd/files')
-rw-r--r--app-crypt/libmd/files/libmd-1.0.3-out-of-source.patch56
-rw-r--r--app-crypt/libmd/files/libmd-1.0.4-fix-version-script-linker-support-detection.patch38
2 files changed, 38 insertions, 56 deletions
diff --git a/app-crypt/libmd/files/libmd-1.0.3-out-of-source.patch b/app-crypt/libmd/files/libmd-1.0.3-out-of-source.patch
deleted file mode 100644
index 77edac0115f0..000000000000
--- a/app-crypt/libmd/files/libmd-1.0.3-out-of-source.patch
+++ /dev/null
@@ -1,56 +0,0 @@
---- a/man/Makefile.am
-+++ b/man/Makefile.am
-@@ -41,7 +41,7 @@
- $(nil)
-
- $(md2_FUNCS): md2.3
-- $(LN_S) -f $< $(DESTDIR)$(man3dir)/$@.3
-+ cd "$(DESTDIR)$(man3dir)" && $(LN_S) -f md2.3 $@.3
-
- md4_FUNCS = \
- MD4Transform \
-@@ -56,7 +56,7 @@
- $(nil)
-
- $(md4_FUNCS): md4.3
-- $(LN_S) -f $< $(DESTDIR)$(man3dir)/$@.3
-+ cd "$(DESTDIR)$(man3dir)" && $(LN_S) -f md4.3 $@.3
-
- md5_FUNCS = \
- MD5Transform \
-@@ -71,7 +71,7 @@
- $(nil)
-
- $(md5_FUNCS): md5.3
-- $(LN_S) -f $< $(DESTDIR)$(man3dir)/$@.3
-+ cd "$(DESTDIR)$(man3dir)" && $(LN_S) -f md5.3 $@.3
-
- rmd160_FUNCS = \
- RMD160Transform \
-@@ -86,7 +86,7 @@
- $(nil)
-
- $(rmd160_FUNCS): rmd160.3
-- $(LN_S) -f $< $(DESTDIR)$(man3dir)/$@.3
-+ cd "$(DESTDIR)$(man3dir)" && $(LN_S) -f rmd160.3 $@.3
-
- sha1_FUNCS = \
- SHA1Transform \
-@@ -101,7 +101,7 @@
- $(nil)
-
- $(sha1_FUNCS): sha1.3
-- $(LN_S) -f $< $(DESTDIR)$(man3dir)/$@.3
-+ cd "$(DESTDIR)$(man3dir)" && $(LN_S) -f sha1.3 $@.3
-
- sha2_FUNCS = \
- SHA256Init \
-@@ -134,7 +134,7 @@
- $(nil)
-
- $(sha2_FUNCS): sha2.3
-- $(LN_S) -f $< $(DESTDIR)$(man3dir)/$@.3
-+ cd "$(DESTDIR)$(man3dir)" && $(LN_S) -f sha2.3 $@.3
-
- digest_FUNCS = \
- $(md2_FUNCS) \
diff --git a/app-crypt/libmd/files/libmd-1.0.4-fix-version-script-linker-support-detection.patch b/app-crypt/libmd/files/libmd-1.0.4-fix-version-script-linker-support-detection.patch
new file mode 100644
index 000000000000..bcee3a06611f
--- /dev/null
+++ b/app-crypt/libmd/files/libmd-1.0.4-fix-version-script-linker-support-detection.patch
@@ -0,0 +1,38 @@
+From e408786075b9540f76783f5c3ce87f6d1ece13cf Mon Sep 17 00:00:00 2001
+From: Guillem Jover <guillem@hadrons.org>
+Date: Sun, 12 Feb 2023 23:55:09 +0100
+Subject: [PATCH] build: Fix version script linker support detection
+
+When the linker uses --no-undefined-version either specified by the user
+or as the default behavior (such as with newer clang >= 16 releases), a missing symbol definition will cause a linker error if that symbol is
+listed in the version script.
+
+
+Bug: https://bugs.gentoo.org/894010
+Upstream issue: https://gitlab.freedesktop.org/libbsd/libmd/-/issues/1
+Upstream commit: https://gitlab.freedesktop.org/libbsd/libmd/-/commit/e408786075b9540f76783f5c3ce87f6d1ece13cf
+
+---
+ m4/libmd-linker.m4 | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/m4/libmd-linker.m4 b/m4/libmd-linker.m4
+index 7d1236a..3d6edcd 100644
+--- a/m4/libmd-linker.m4
++++ b/m4/libmd-linker.m4
+@@ -8,7 +8,11 @@ AC_DEFUN([LIBMD_LINKER_VERSION_SCRIPT], [
+ save_LDFLAGS=$LDFLAGS
+ LDFLAGS="$LDFLAGS -Wl,--version-script=conftest.map"
+ AC_LINK_IFELSE([
+- AC_LANG_PROGRAM([], [])
++ AC_LANG_PROGRAM([[
++extern int symbol(void);
++int symbol(void) { return 0; }
++]], [[
++]])
+ ], [
+ libmd_cv_version_script=yes
+ ], [
+--
+GitLab
+