summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/libu2f-host')
-rw-r--r--app-crypt/libu2f-host/libu2f-host-1.1.10-r1.ebuild (renamed from app-crypt/libu2f-host/libu2f-host-1.1.10.ebuild)16
1 files changed, 9 insertions, 7 deletions
diff --git a/app-crypt/libu2f-host/libu2f-host-1.1.10.ebuild b/app-crypt/libu2f-host/libu2f-host-1.1.10-r1.ebuild
index dc653e48ba0b..e56d5ffbf913 100644
--- a/app-crypt/libu2f-host/libu2f-host-1.1.10.ebuild
+++ b/app-crypt/libu2f-host/libu2f-host-1.1.10-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit linux-info udev
@@ -12,7 +12,7 @@ SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.xz"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm64 ~ppc64 x86"
-IUSE="kernel_linux systemd"
+IUSE="systemd"
DEPEND="dev-libs/hidapi
dev-libs/json-c:="
@@ -27,10 +27,6 @@ CONFIG_CHECK="~HIDRAW"
PATCHES=( "${FILESDIR}/${P}-json-boolean.patch" )
-src_configure() {
- econf --disable-static
-}
-
src_install() {
default
if use kernel_linux; then
@@ -41,8 +37,14 @@ src_install() {
}
pkg_postinst() {
+ udev_reload
+
if ! use systemd; then
elog "Users must be a member of the 'plugdev' group"
elog "to be able to access U2F devices"
fi
}
+
+pkg_postrm() {
+ udev_reload
+}