summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/nasty')
-rw-r--r--app-crypt/nasty/nasty-0.6-r2.ebuild (renamed from app-crypt/nasty/nasty-0.6-r1.ebuild)18
1 files changed, 7 insertions, 11 deletions
diff --git a/app-crypt/nasty/nasty-0.6-r1.ebuild b/app-crypt/nasty/nasty-0.6-r2.ebuild
index 574cd87cb1de..2596a2964bf5 100644
--- a/app-crypt/nasty/nasty-0.6-r1.ebuild
+++ b/app-crypt/nasty/nasty-0.6-r2.ebuild
@@ -1,32 +1,28 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs
DESCRIPTION="Proof-of-concept GPG passphrase recovery tool"
HOMEPAGE="http://www.vanheusden.com/nasty/"
SRC_URI="http://www.vanheusden.com/nasty/${P}.tgz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RDEPEND="app-crypt/gpgme"
-DEPEND="${RDEPEND}"
-DOCS=(
- readme.txt
-)
+RDEPEND="app-crypt/gpgme:="
+DEPEND="${RDEPEND}"
-PATCHES=(
- "${FILESDIR}/${P}-flags.patch"
-)
+PATCHES=( "${FILESDIR}"/${P}-flags.patch )
src_compile() {
emake CC="$(tc-getCC)" DEBUG=
}
src_install() {
- einstalldocs
dobin nasty
+ dodoc readme.txt
}