summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06-r2.ebuild')
-rw-r--r--app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06-r2.ebuild b/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06-r2.ebuild
new file mode 100644
index 000000000000..fe55cfddc7f0
--- /dev/null
+++ b/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/ThomasHabets/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ThomasHabets/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Simple PKCS11 provider for TPM chips"
+HOMEPAGE="https://github.com/ThomasHabets/simple-tpm-pk11"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+RESTRICT="test" # needs to communicate with the TPM and gtest is all broken
+
+DEPEND="
+ app-crypt/tpm-tools[pkcs11]
+ app-crypt/trousers
+ dev-libs/opencryptoki[tpm]
+ dev-libs/openssl:=
+"
+RDEPEND="${DEPEND}
+ || (
+ >=net-misc/openssh-9.3_p1-r1
+ >=net-misc/openssh-contrib-9.3_p1[-X509]
+ )
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}