summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06.ebuild')
-rw-r--r--app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06.ebuild b/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06.ebuild
deleted file mode 100644
index 5cf849aa0d26..000000000000
--- a/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools
-
-DESCRIPTION="Simple PKCS11 provider for TPM chips"
-HOMEPAGE="https://github.com/ThomasHabets/simple-tpm-pk11"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/ThomasHabets/${PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/ThomasHabets/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-IUSE="libressl"
-RESTRICT="test" # needs to communicate with the TPM and gtest is all broken
-
-DEPEND="app-crypt/tpm-tools[pkcs11]
- dev-libs/opencryptoki[tpm]
- app-crypt/trousers
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )"
-RDEPEND="${DEPEND}
- net-misc/openssh[-X509]"
-
-src_prepare() {
- eapply_user
- eautoreconf
-}
-
-src_configure() {
- econf --disable-static
-}
-
-src_install() {
- default
- find "${ED}" -name '*.la' -delete || die
-}