summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/simple-tpm-pk11')
-rw-r--r--app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06-r2.ebuild (renamed from app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06.ebuild)37
1 files changed, 19 insertions, 18 deletions
diff --git a/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06.ebuild b/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06-r2.ebuild
index 64abb36d4de1..fe55cfddc7f0 100644
--- a/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06.ebuild
+++ b/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06-r2.ebuild
@@ -1,16 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools
-DESCRIPTION="Simple PKCS11 provider for TPM chips"
-HOMEPAGE="https://github.com/ThomasHabets/simple-tpm-pk11"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-if [[ ${PV} == "9999" ]]; then
+if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/ThomasHabets/${PN}.git"
inherit git-r3
else
@@ -18,25 +13,31 @@ else
KEYWORDS="~amd64"
fi
+DESCRIPTION="Simple PKCS11 provider for TPM chips"
+HOMEPAGE="https://github.com/ThomasHabets/simple-tpm-pk11"
+
+LICENSE="Apache-2.0"
+SLOT="0"
RESTRICT="test" # needs to communicate with the TPM and gtest is all broken
-DEPEND="app-crypt/tpm-tools[pkcs11]
- dev-libs/opencryptoki[tpm]
+DEPEND="
+ app-crypt/tpm-tools[pkcs11]
app-crypt/trousers
- dev-libs/openssl:0=
- "
+ dev-libs/opencryptoki[tpm]
+ dev-libs/openssl:=
+"
RDEPEND="${DEPEND}
- net-misc/openssh[-X509]"
+ || (
+ >=net-misc/openssh-9.3_p1-r1
+ >=net-misc/openssh-contrib-9.3_p1[-X509]
+ )
+"
src_prepare() {
- eapply_user
+ default
eautoreconf
}
-src_configure() {
- econf --disable-static
-}
-
src_install() {
default
find "${ED}" -name '*.la' -delete || die