summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/stoken')
-rw-r--r--app-crypt/stoken/stoken-0.92-r3.ebuild (renamed from app-crypt/stoken/stoken-0.92-r2.ebuild)12
1 files changed, 6 insertions, 6 deletions
diff --git a/app-crypt/stoken/stoken-0.92-r2.ebuild b/app-crypt/stoken/stoken-0.92-r3.ebuild
index 71f62bf2c30a..11e11adeb2f1 100644
--- a/app-crypt/stoken/stoken-0.92-r2.ebuild
+++ b/app-crypt/stoken/stoken-0.92-r3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=8
inherit autotools
@@ -12,13 +12,14 @@ SRC_URI="https://github.com/cernekee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-2.1+"
SLOT="0"
KEYWORDS="amd64 arm arm64 ~loong ppc64 ~riscv x86"
-IUSE="gtk static-libs"
+IUSE="gtk"
# TODO: add a USE flag to enable optional use of tomcrypt instead of nettle.
RDEPEND="
- dev-libs/nettle
- gtk? ( >=x11-libs/gtk+-3.12:3 )"
+ dev-libs/nettle:=
+ gtk? ( x11-libs/gtk+:3 )"
DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
src_prepare() {
default
@@ -28,7 +29,6 @@ src_prepare() {
src_configure() {
local myconf=(
$(use_with gtk)
- $(use_enable static-libs static)
--with-nettle
--without-tomcrypt
)