summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/swtpm')
-rw-r--r--app-crypt/swtpm/Manifest4
-rw-r--r--app-crypt/swtpm/swtpm-0.8.1-r2.ebuild (renamed from app-crypt/swtpm/swtpm-0.7.3.ebuild)25
-rw-r--r--app-crypt/swtpm/swtpm-0.8.2.ebuild (renamed from app-crypt/swtpm/swtpm-0.8.0.ebuild)28
3 files changed, 31 insertions, 26 deletions
diff --git a/app-crypt/swtpm/Manifest b/app-crypt/swtpm/Manifest
index 5091e8127e17..39622bc498e0 100644
--- a/app-crypt/swtpm/Manifest
+++ b/app-crypt/swtpm/Manifest
@@ -1,2 +1,2 @@
-DIST swtpm-0.7.3.tar.gz 354088 BLAKE2B 687e3161cbc08be68427648187ba2fb05749bcaaf9929b951eea4884bd4210c6105a2494f5e7d51915e5be1b700b13889cd83c96d22e00d621ea9336221ee67b SHA512 7f4cdf7ca2539f28e3a78e2a081b24983f3305905c7cafcac0957b14f5c06c8ee9485a0adaf3710561091f9ee85e00822fe1ff874389808218c1e17f938c45d9
-DIST swtpm-0.8.0.tar.gz 363951 BLAKE2B 8ec91961c5ac145dc5d1c3c4a609d18bc425caef0efb4d2b18c08c76acacefa619617b6e7b6e8e4e707117a29e3ff3c0198b63d81d24fc747435c6e06e48e8e9 SHA512 7f70c19f732404061be6168c96c0dd3ec91ed8b50dddcafcb50d810062ce0e83ad85360191f97db5db9dc034e01d91cebe3912449d896d2cde68fe060a0adb09
+DIST swtpm-0.8.1.tar.gz 364169 BLAKE2B 4b364ed581ea97d78c5c6248870503b1612d7d164b05b76c1f02644aade6fd09f204396f0a2d0db4e0ecec2792dc512f7c4393c44bf7ce447a3a7fbb8754594f SHA512 07276519b0e20c9c4167ce78e789d2072eb90172ed9bcba2a11eef46ee03a77860f7a2218f4dc013a2ddb8471079e3cbe43f8ab02174bd704a78aea8eee3d2fc
+DIST swtpm-0.8.2.tar.gz 364432 BLAKE2B 1ffa6feed88a67a2eeea1fca1c034f6513347173d59ae0c0654696faa1e791529e7fa044c478e5fb7e016117ce5f3151b875014d85eac528e4b6d92d5cf9017b SHA512 3b63116b1ed56087e05b0b697462720a10fe384ea2b8ec7115b549df8f557f6a9cf4de8e7d65b8061a1c85e54e015e0249bfbb613d35c1b64453a98d23ce334f
diff --git a/app-crypt/swtpm/swtpm-0.7.3.ebuild b/app-crypt/swtpm/swtpm-0.8.1-r2.ebuild
index 4ae448778f9c..650e54402d13 100644
--- a/app-crypt/swtpm/swtpm-0.7.3.ebuild
+++ b/app-crypt/swtpm/swtpm-0.8.1-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9,10,11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit autotools python-any-r1
@@ -13,30 +13,33 @@ SRC_URI="https://github.com/stefanberger/swtpm/archive/v${PV}.tar.gz -> ${P}.tar
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv x86"
-IUSE="fuse +gnutls seccomp test"
+KEYWORDS="amd64 arm arm64 ~loong ~ppc ppc64 ~riscv x86"
+IUSE="fuse seccomp test"
RESTRICT="!test? ( test )"
+# net-libs/gnutls[pkcs11,tools] is required otherwsie it not possible to
+# provision new vTPMs. swtpm_cert spawns certttool, and upstream expects
+# pkcs11 in gnutls: https://github.com/stefanberger/swtpm/issues/477.
+
RDEPEND="fuse? (
dev-libs/glib:2
sys-fs/fuse:0
)
- gnutls? (
- dev-libs/libtasn1:=
- >=net-libs/gnutls-3.1.0:=[tools,pkcs11]
- )
seccomp? ( sys-libs/libseccomp )
acct-group/tss
acct-user/tss
dev-libs/openssl:0=
dev-libs/json-glib
- dev-libs/libtpms"
+ dev-libs/libtpms
+ dev-libs/libtasn1:=
+ net-libs/gnutls[pkcs11,tools]
+"
DEPEND="${RDEPEND}
- test? (
+ test? (
net-misc/socat
dev-tcltk/expect
- )"
+ )"
BDEPEND="${PYTHON_DEPS}"
@@ -54,9 +57,9 @@ src_prepare() {
src_configure() {
econf \
--with-openssl \
+ --with-gnutls \
--without-selinux \
$(use_with fuse cuse) \
- $(use_with gnutls) \
$(use_with seccomp) \
$(use_enable test)
}
diff --git a/app-crypt/swtpm/swtpm-0.8.0.ebuild b/app-crypt/swtpm/swtpm-0.8.2.ebuild
index 3fd090a2bc24..a1857927a41f 100644
--- a/app-crypt/swtpm/swtpm-0.8.0.ebuild
+++ b/app-crypt/swtpm/swtpm-0.8.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9,10,11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit autotools python-any-r1
@@ -14,36 +14,38 @@ SRC_URI="https://github.com/stefanberger/swtpm/archive/v${PV}.tar.gz -> ${P}.tar
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
-IUSE="fuse +gnutls seccomp test"
+IUSE="fuse seccomp test"
RESTRICT="!test? ( test )"
+# net-libs/gnutls[pkcs11,tools] is required otherwsie it not possible to
+# provision new vTPMs. swtpm_cert spawns certttool, and upstream expects
+# pkcs11 in gnutls: https://github.com/stefanberger/swtpm/issues/477.
+
RDEPEND="fuse? (
dev-libs/glib:2
sys-fs/fuse:0
)
- gnutls? (
- dev-libs/libtasn1:=
- >=net-libs/gnutls-3.4.0:=[tools,pkcs11]
- )
seccomp? ( sys-libs/libseccomp )
acct-group/tss
acct-user/tss
dev-libs/openssl:0=
dev-libs/json-glib
- dev-libs/libtpms"
+ dev-libs/libtpms
+ dev-libs/libtasn1:=
+ net-libs/gnutls[pkcs11,tools]
+"
DEPEND="${RDEPEND}
- test? (
+ test? (
net-misc/socat
dev-tcltk/expect
- )"
+ )"
BDEPEND="${PYTHON_DEPS}"
PATCHES=(
"${FILESDIR}/${PN}-0.6.0-fix-localca-path.patch"
"${FILESDIR}/${PN}-0.5.0-build-sys-Remove-WError.patch"
- "${FILESDIR}/${PN}-0.7.2-Conditionalize-test-dependencies.patch"
)
src_prepare() {
@@ -54,11 +56,11 @@ src_prepare() {
src_configure() {
econf \
--with-openssl \
+ --with-gnutls \
--without-selinux \
$(use_with fuse cuse) \
- $(use_with gnutls) \
$(use_with seccomp) \
- $(use_enable test)
+ $(use_enable test tests)
}
src_install() {