summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/tc-play')
-rw-r--r--app-crypt/tc-play/Manifest1
-rw-r--r--app-crypt/tc-play/files/tc-play-2.0-build.patch27
-rw-r--r--app-crypt/tc-play/metadata.xml8
-rw-r--r--app-crypt/tc-play/tc-play-2.0-r2.ebuild60
4 files changed, 4 insertions, 92 deletions
diff --git a/app-crypt/tc-play/Manifest b/app-crypt/tc-play/Manifest
index 4cbb6d555306..e3b5b83c56e4 100644
--- a/app-crypt/tc-play/Manifest
+++ b/app-crypt/tc-play/Manifest
@@ -1,2 +1 @@
-DIST tc-play-2.0.tar.gz 1015525 BLAKE2B 1481eecc8aaf2cb9698eed96a9cdabaa2b74daf11865dd29a6fab7e66fb76aa2f6e544fe7ac53a2510415ee6ddf3c5732c774a26708fe354113eb9de6a9b62d9 SHA512 17408b2a664eb6822c77ede4f38ca67cdf643512014619d830a2c024bb8971811eded4edd65f6398d6112a3b57cd11a5b414357878c817c9cc2aac9d851946d7
DIST tc-play-3.3.tar.gz 2591752 BLAKE2B c02489d6e291dfc1425745af86506e72fda7f67dba0668b9250a85604ba301761b5bbbad6927238042a0f89da1035d9e3275006e34e895835a53cdc24974f419 SHA512 78cc84b1ca333e6760b87dfd22035a027bea8d562201c028247e9cfc4377260490cdc42236ef1eeb1c263a49ca1654d8ae637abdf1b4e507f958bc780fc85d94
diff --git a/app-crypt/tc-play/files/tc-play-2.0-build.patch b/app-crypt/tc-play/files/tc-play-2.0-build.patch
deleted file mode 100644
index 0385f33b45b4..000000000000
--- a/app-crypt/tc-play/files/tc-play-2.0-build.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 3f9235841ba4494962b3c7dafcd16fd3ff5f6575 Mon Sep 17 00:00:00 2001
-From: Alon Bar-Lev <alon.barlev@gmail.com>
-Date: Sat, 8 Apr 2017 20:27:17 +0300
-Subject: [PATCH] build: include sys/sysmacros.h for recent glibc
-
-https://sourceware.org/ml/libc-alpha/2015-11/msg00253.html
-
-Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
----
- tcplay.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/tcplay.c b/tcplay.c
-index cd882cf..a6d4655 100644
---- a/tcplay.c
-+++ b/tcplay.c
-@@ -47,6 +47,7 @@
- #if defined(__linux__)
- #include <libdevmapper.h>
- #include <uuid/uuid.h>
-+#include <sys/sysmacros.h>
- #elif defined(__DragonFly__)
- #include <libdm.h>
- #include <uuid.h>
---
-2.10.2
-
diff --git a/app-crypt/tc-play/metadata.xml b/app-crypt/tc-play/metadata.xml
index 683a10b4df2a..ce2564530426 100644
--- a/app-crypt/tc-play/metadata.xml
+++ b/app-crypt/tc-play/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="github">bwalex/tc-play</remote-id>
- </upstream>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">bwalex/tc-play</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/app-crypt/tc-play/tc-play-2.0-r2.ebuild b/app-crypt/tc-play/tc-play-2.0-r2.ebuild
deleted file mode 100644
index 244696e5f144..000000000000
--- a/app-crypt/tc-play/tc-play-2.0-r2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs
-
-DESCRIPTION="A free, pretty much fully featured and stable TrueCrypt implementation"
-HOMEPAGE="https://github.com/bwalex/tc-play"
-SRC_URI="https://github.com/bwalex/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="gnutls"
-
-DEPEND="
- dev-libs/libgcrypt:=
- dev-libs/libgpg-error
- sys-apps/util-linux
- sys-fs/lvm2
- gnutls? ( net-libs/gnutls )
- !gnutls? (
- dev-libs/openssl:=
- )
-"
-RDEPEND="${DEPEND}"
-
-DOCS=( README.md )
-
-PATCHES=(
- "${FILESDIR}/${P}-build.patch"
-)
-
-pkg_setup() {
- local backend="openssl"
- use gnutls && local backend="gcrypt"
-
- EXTRA_MAKE_FLAGS=(
- PBKDF_BACKEND="${backend}"
- WARNFLAGS=""
- CC="$(tc-getCC)"
- AR="$(tc-getAR)"
- PREFIX=/usr
- LIBDIR=/usr/$(get_libdir)
- )
-}
-
-src_compile() {
- emake -f Makefile.classic \
- tcplay \
- "${EXTRA_MAKE_FLAGS[@]}"
-}
-
-src_install() {
- emake -f Makefile.classic \
- "${EXTRA_MAKE_FLAGS[@]}" \
- install_program \
- DESTDIR="${ED}"
-}