summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/tpm-emulator/files')
-rw-r--r--app-crypt/tpm-emulator/files/tpm-emulator-0.7.5-build.patch33
-rw-r--r--app-crypt/tpm-emulator/files/tpm-emulator-0.7.5-fno-common.patch48
-rw-r--r--app-crypt/tpm-emulator/files/tpm-emulator-0.7.5-static-libs.patch26
-rw-r--r--app-crypt/tpm-emulator/files/tpm-emulator.confd1
-rw-r--r--app-crypt/tpm-emulator/files/tpm-emulator.initd46
5 files changed, 0 insertions, 154 deletions
diff --git a/app-crypt/tpm-emulator/files/tpm-emulator-0.7.5-build.patch b/app-crypt/tpm-emulator/files/tpm-emulator-0.7.5-build.patch
deleted file mode 100644
index 3f96bdd3e68f..000000000000
--- a/app-crypt/tpm-emulator/files/tpm-emulator-0.7.5-build.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 78f018a79243b8aa3c2a8e8aa87245c58c731278 Mon Sep 17 00:00:00 2001
-From: Alon Bar-Lev <alon.barlev@gmail.com>
-Date: Sun, 16 Sep 2018 13:29:59 +0300
-Subject: [PATCH] tpmd_dev: fix strncpy bound
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-tpmd_dev/linux/tpmd_dev.c:88:3: error: ‘strncpy’ specified bound 108 equals destination size [-Werror=stringop-truncation]
-
-Bug: https://github.com/PeterHuewe/tpm-emulator/pull/43
-
-Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
----
- tpmd_dev/linux/tpmd_dev.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tpmd_dev/linux/tpmd_dev.c b/tpmd_dev/linux/tpmd_dev.c
-index 2b24bd7..72583f4 100644
---- a/tpmd_dev/linux/tpmd_dev.c
-+++ b/tpmd_dev/linux/tpmd_dev.c
-@@ -85,7 +85,7 @@ static int tpmd_connect(char *socket_name)
- return res;
- }
- addr.sun_family = AF_UNIX;
-- strncpy(addr.sun_path, socket_name, sizeof(addr.sun_path));
-+ strncpy(addr.sun_path, socket_name, sizeof(addr.sun_path)-1);
- res = tpmd_sock->ops->connect(tpmd_sock,
- (struct sockaddr*)&addr, sizeof(struct sockaddr_un), 0);
- if (res != 0) {
---
-2.16.4
-
diff --git a/app-crypt/tpm-emulator/files/tpm-emulator-0.7.5-fno-common.patch b/app-crypt/tpm-emulator/files/tpm-emulator-0.7.5-fno-common.patch
deleted file mode 100644
index 88bfb33433c1..000000000000
--- a/app-crypt/tpm-emulator/files/tpm-emulator-0.7.5-fno-common.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-https://bugs.gentoo.org/707256
---- a/tpm/tpm_emulator_extern.h
-+++ b/tpm/tpm_emulator_extern.h
-@@ -29,7 +29,7 @@ enum {
- TPM_LOG_ERROR
- };
-
--void (*tpm_log)(int priority, const char *fmt, ...);
-+extern void (*tpm_log)(int priority, const char *fmt, ...);
-
- #if defined(_WIN32) || defined(_WIN64)
- #define __BFILE__ ((strrchr(__FILE__, '\\') ? : __FILE__ - 1) + 1)
-@@ -44,27 +44,27 @@ void (*tpm_log)(int priority, const char *fmt, ...);
- #define error(fmt, ...) tpm_log(TPM_LOG_ERROR, "%s:%d: Error: " fmt "\n", \
- __BFILE__, __LINE__, ## __VA_ARGS__)
- /* initialization */
--int (*tpm_extern_init)(void);
--void (*tpm_extern_release)(void);
-+extern int (*tpm_extern_init)(void);
-+extern void (*tpm_extern_release)(void);
-
- /* memory allocation */
-
--void* (*tpm_malloc)(size_t size);
-+extern void* (*tpm_malloc)(size_t size);
-
--void (*tpm_free)(/*const*/ void *ptr);
-+extern void (*tpm_free)(/*const*/ void *ptr);
-
- /* random numbers */
-
--void (*tpm_get_extern_random_bytes)(void *buf, size_t nbytes);
-+extern void (*tpm_get_extern_random_bytes)(void *buf, size_t nbytes);
-
- /* usec since last call */
-
--uint64_t (*tpm_get_ticks)(void);
-+extern uint64_t (*tpm_get_ticks)(void);
-
- /* file handling */
-
--int (*tpm_write_to_storage)(uint8_t *data, size_t data_length);
--int (*tpm_read_from_storage)(uint8_t **data, size_t *data_length);
-+extern int (*tpm_write_to_storage)(uint8_t *data, size_t data_length);
-+extern int (*tpm_read_from_storage)(uint8_t **data, size_t *data_length);
-
- #endif /* _TPM_EMULATOR_EXTERN_H_ */
-
diff --git a/app-crypt/tpm-emulator/files/tpm-emulator-0.7.5-static-libs.patch b/app-crypt/tpm-emulator/files/tpm-emulator-0.7.5-static-libs.patch
deleted file mode 100644
index 845229bd7670..000000000000
--- a/app-crypt/tpm-emulator/files/tpm-emulator-0.7.5-static-libs.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-https://bugs.gentoo.org/726492
---- a/tddl/CMakeLists.txt
-+++ b/tddl/CMakeLists.txt
-@@ -5,21 +5,18 @@
-
- set(tddl-tpm-emulator_SRCS "tddl.c" "tddl-tpm-emulator.h")
- add_library(tddl-tpm-emulator SHARED ${tddl-tpm-emulator_SRCS})
--add_library(tddl-tpm-emulator_static STATIC ${tddl-tpm-emulator_SRCS})
- if(UNIX)
- set_target_properties(tddl-tpm-emulator PROPERTIES SOVERSION "1.2"
- VERSION "1.2.${${PROJECT_NAME}_VERSION_MAJOR}.${${PROJECT_NAME}_VERSION_MINOR}")
-- set_target_properties(tddl-tpm-emulator_static PROPERTIES OUTPUT_NAME tddl-tpm-emulator)
- elseif(WIN32)
- set_target_properties(tddl-tpm-emulator PROPERTIES OUTPUT_NAME ifxtpm)
- set_target_properties(tddl-tpm-emulator PROPERTIES PREFIX "")
- endif()
-
- install(TARGETS tddl-tpm-emulator DESTINATION ${CMAKE_INSTALL_LIBDIR})
--install(TARGETS tddl-tpm-emulator_static DESTINATION ${CMAKE_INSTALL_LIBDIR})
- install(FILES "tddl-tpm-emulator.h" DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
-
- include_directories(${CMAKE_CURRENT_SOURCE_DIR})
- add_executable(test_tddl test_tddl.c)
--target_link_libraries(test_tddl tddl-tpm-emulator_static)
-+target_link_libraries(test_tddl tddl-tpm-emulator)
-
diff --git a/app-crypt/tpm-emulator/files/tpm-emulator.confd b/app-crypt/tpm-emulator/files/tpm-emulator.confd
deleted file mode 100644
index 985fa4e774ca..000000000000
--- a/app-crypt/tpm-emulator/files/tpm-emulator.confd
+++ /dev/null
@@ -1 +0,0 @@
-STARTUP_MODE="save"
diff --git a/app-crypt/tpm-emulator/files/tpm-emulator.initd b/app-crypt/tpm-emulator/files/tpm-emulator.initd
deleted file mode 100644
index abfbef900d00..000000000000
--- a/app-crypt/tpm-emulator/files/tpm-emulator.initd
+++ /dev/null
@@ -1,46 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License, v2 or later
-
-STARTUP_MODE="${STARTUP_MODE:-save}";
-
-extra_started_commands="clear save deactivated"
-description="TPM emulator"
-command="/usr/bin/tpmd"
-my_command_args="-f"
-command_background=1
-command_user="tss:tss"
-pidfile="/var/run/${RC_SVCNAME}.pid"
-
-depend() {
- use logger
- after coldplug
-}
-
-start_pre() {
- checkpath -d -m 0775 -o tss /var/run/tpm
- service_set_value STARTUP_MODE "${STARTUP_MODE}"
-}
-
-start() {
- command_args="${my_command_args} $(service_get_value STARTUP_MODE)"
- default_start
-}
-
-_doit() {
- service_set_value STARTUP_MODE "$1"
- stop
- start
-}
-
-clear() {
- _doit clear
-}
-
-save() {
- _doit save
-}
-
-deactivated() {
- _doit deactivated
-}