summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/tpm2-abrmd')
-rw-r--r--app-crypt/tpm2-abrmd/Manifest2
-rw-r--r--app-crypt/tpm2-abrmd/files/tpm2-abrmd.initd1
-rw-r--r--app-crypt/tpm2-abrmd/tpm2-abrmd-3.0.0-r2.ebuild (renamed from app-crypt/tpm2-abrmd/tpm2-abrmd-2.4.1-r1.ebuild)18
3 files changed, 12 insertions, 9 deletions
diff --git a/app-crypt/tpm2-abrmd/Manifest b/app-crypt/tpm2-abrmd/Manifest
index ab9d8884a85b..8c789db744a8 100644
--- a/app-crypt/tpm2-abrmd/Manifest
+++ b/app-crypt/tpm2-abrmd/Manifest
@@ -1 +1 @@
-DIST tpm2-abrmd-2.4.1.tar.gz 577259 BLAKE2B 7d97e1069a171f3693fb11b8e2ce0243993f4352aae9fd691bfbf1b8fcef8615b79957f8f662ac00fe59bf7e3830d8abb79c67790f7be1cd3140fd1c7b1ed560 SHA512 0335285678cfceca4f185981ded90d213ff796cadddc9b5d6dbf2db533f81023a0f1089bbd8a8017bccb95190889be23b24d38a176d3368d221479aff4ff7d6c
+DIST tpm2-abrmd-3.0.0.tar.gz 576822 BLAKE2B cdcb677a2dec59cdc454b98793bb0784ba3403c276b618cd37c5748ab1d883ee8f3f69c0ae95c7bf262e2e993dcc0b12ae39010de12c6c211fe3de8c21515160 SHA512 65a39cd0518dfbcbd5835ac6c6628444d412e36471702f2cd1f1077d788330a477778e6403899ea2fa0497b643e5db9ca3e746845492eff78c4c78d8dd8f9e7d
diff --git a/app-crypt/tpm2-abrmd/files/tpm2-abrmd.initd b/app-crypt/tpm2-abrmd/files/tpm2-abrmd.initd
index 0272921dcbd7..c07f8e757eb9 100644
--- a/app-crypt/tpm2-abrmd/files/tpm2-abrmd.initd
+++ b/app-crypt/tpm2-abrmd/files/tpm2-abrmd.initd
@@ -10,6 +10,7 @@ command_user="tss:tss"
pidfile="/var/run/${RC_SVCNAME}.pid"
depend() {
+ need dbus
use logger
after coldplug
}
diff --git a/app-crypt/tpm2-abrmd/tpm2-abrmd-2.4.1-r1.ebuild b/app-crypt/tpm2-abrmd/tpm2-abrmd-3.0.0-r2.ebuild
index ed4032c44ca0..a2ba6892bc2a 100644
--- a/app-crypt/tpm2-abrmd/tpm2-abrmd-2.4.1-r1.ebuild
+++ b/app-crypt/tpm2-abrmd/tpm2-abrmd-3.0.0-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools systemd
+inherit autotools flag-o-matic systemd
DESCRIPTION="TPM2 Access Broker & Resource Manager"
HOMEPAGE="https://github.com/tpm2-software/tpm2-abrmd"
@@ -36,12 +36,14 @@ src_prepare() {
}
src_configure() {
+ # tests fail with LTO enabbled. See bug 865275
+ filter-lto
econf \
$(use_enable static-libs static) \
$(use_enable test unit) \
$(use_enable test integration) \
--disable-defaultflags \
- --with-dbuspolicydir="${EPREFIX}/etc/dbus-1/system.d" \
+ --with-dbuspolicydir="${EPREFIX}/usr/share/dbus-1/system.d" \
--with-systemdpresetdir="$(systemd_get_systemunitdir)/../system-preset" \
--with-systemdpresetdisable \
--with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
@@ -50,13 +52,13 @@ src_configure() {
src_install() {
default
- if [[ ${PV} != $(sed -n -e 's/^Version: //p' "${ED}/usr/$(get_libdir)/pkgconfig/tss2-tcti-tabrmd.pc" || die) ]] ; then
- # Safeguard for bug #833887
- die "pkg-config file version doesn't match ${PV}! Please report a bug!"
- fi
-
find "${D}" -name '*.la' -delete || die
newinitd "${FILESDIR}"/${PN}.initd ${PN}
newconfd "${FILESDIR}"/${PN}.confd ${PN}
}
+
+pkg_postinst() {
+ einfo "As of tpm2-abrmd 3.0.0, users must be in the tss group"
+ einfo "to access the TPM"
+}