summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/tpm2-pkcs11')
-rw-r--r--app-crypt/tpm2-pkcs11/Manifest2
-rw-r--r--app-crypt/tpm2-pkcs11/files/tpm2-pkcs11-1.9.0-Remove-incorrect-append-in-configure-ac.patch26
-rw-r--r--app-crypt/tpm2-pkcs11/metadata.xml3
-rw-r--r--app-crypt/tpm2-pkcs11/tpm2-pkcs11-1.9.0-r2.ebuild (renamed from app-crypt/tpm2-pkcs11/tpm2-pkcs11-1.8.0.ebuild)17
4 files changed, 43 insertions, 5 deletions
diff --git a/app-crypt/tpm2-pkcs11/Manifest b/app-crypt/tpm2-pkcs11/Manifest
index 44be70f79ef8..bc5672346cb0 100644
--- a/app-crypt/tpm2-pkcs11/Manifest
+++ b/app-crypt/tpm2-pkcs11/Manifest
@@ -1 +1 @@
-DIST tpm2-pkcs11-1.8.0.tar.gz 1393977 BLAKE2B c959e9e593dde903eac4b26ac85a39d1c73bfb9b6be558d7338dae1a710eb836385b08ddca27689f0573242d40ee072fa5d6685186a50e10ea42b8679389cf92 SHA512 599feb4d888c25a3359927b1d408f9ce85ba69d8a0e7af7ae9f3736e8940ec8d5f58b3094bef3b6515c0b1810249ea98cd73dbce592cb63de3b45ff976adda80
+DIST tpm2-pkcs11-1.9.0.tar.gz 1396590 BLAKE2B a5880b61463154d8f17549c442c7eca49b7a438335c264022d81fa93079b83633cba8ff8c3377f5829a896e6f5f55688018d8c3a78cb8223a888c7d6bfcaf555 SHA512 e88e78790a8d4d5a67713855106860e90dd18da00dc738ca7bfebf7979cdde54ce5089d0be015e7a208117bf393db700ca7739986c5e8138ee0e3b37344614b0
diff --git a/app-crypt/tpm2-pkcs11/files/tpm2-pkcs11-1.9.0-Remove-incorrect-append-in-configure-ac.patch b/app-crypt/tpm2-pkcs11/files/tpm2-pkcs11-1.9.0-Remove-incorrect-append-in-configure-ac.patch
new file mode 100644
index 000000000000..10272341fe42
--- /dev/null
+++ b/app-crypt/tpm2-pkcs11/files/tpm2-pkcs11-1.9.0-Remove-incorrect-append-in-configure-ac.patch
@@ -0,0 +1,26 @@
+From 03bc2732826443328550358ba8f2c79195922bc8 Mon Sep 17 00:00:00 2001
+From: Christopher Byrne <salah.coronya@gmail.com>
+Date: Wed, 7 Feb 2024 14:55:38 -0600
+Subject: [PATCH] configure: Change mistaken += to =
+
+Signed-off-by: Christopher Byrne <salah.coronya@gmail.com>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 771004b..0f1457e 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -540,7 +540,7 @@ and submitting patches upstream!])
+ # Rather than nesting these and making them ugly just use a counter.
+ AX_CHECK_COMPILE_FLAG([-fdata-sections], [strip=y])
+ AX_CHECK_COMPILE_FLAG([-ffunction-sections], [strip="y$strip"])
+-AX_CHECK_LINK_FLAG([[-Wl,--gc-sections]], [strip+="y$strip"])
++AX_CHECK_LINK_FLAG([[-Wl,--gc-sections]], [strip="y$strip"])
+
+ AS_IF([test x"$strip" = xyyy], [
+ EXTRA_CFLAGS="$EXTRA_CFLAGS -fdata-sections -ffunction-sections"
+--
+2.43.0
+
diff --git a/app-crypt/tpm2-pkcs11/metadata.xml b/app-crypt/tpm2-pkcs11/metadata.xml
index 12ab3f529d15..4b7a498cda7f 100644
--- a/app-crypt/tpm2-pkcs11/metadata.xml
+++ b/app-crypt/tpm2-pkcs11/metadata.xml
@@ -12,4 +12,7 @@
<use>
<flag name="fapi">Enable feature API backend</flag>
</use>
+ <upstream>
+ <remote-id type="github">tpm2-software/tpm2-pkcs11</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/app-crypt/tpm2-pkcs11/tpm2-pkcs11-1.8.0.ebuild b/app-crypt/tpm2-pkcs11/tpm2-pkcs11-1.9.0-r2.ebuild
index 5a58280d4e3b..2efa0a2d8d04 100644
--- a/app-crypt/tpm2-pkcs11/tpm2-pkcs11-1.8.0.ebuild
+++ b/app-crypt/tpm2-pkcs11/tpm2-pkcs11-1.9.0-r2.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="sqlite"
-inherit python-single-r1
+inherit autotools python-single-r1
DESCRIPTION="A PKCS#11 interface for TPM2 hardware"
HOMEPAGE="https://tpm2-software.github.io/"
@@ -44,9 +44,18 @@ RDEPEND="${PYTHON_DEPS}
DEPEND="test? ( dev-util/cmocka )
${RDEPEND}"
BDEPEND="${PYTHON_DEPS}
- sys-devel/autoconf-archive
+ dev-build/autoconf-archive
virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}/${PN}-1.9.0-Remove-incorrect-append-in-configure-ac.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
econf \
$(use_enable fapi) \