summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/yubihsm-connector/yubihsm-connector-3.0.4.ebuild')
-rw-r--r--app-crypt/yubihsm-connector/yubihsm-connector-3.0.4.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-crypt/yubihsm-connector/yubihsm-connector-3.0.4.ebuild b/app-crypt/yubihsm-connector/yubihsm-connector-3.0.4.ebuild
new file mode 100644
index 000000000000..2eb8fd785e8a
--- /dev/null
+++ b/app-crypt/yubihsm-connector/yubihsm-connector-3.0.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module systemd udev
+
+DESCRIPTION="Server to expose YubiHSM 2 to network"
+HOMEPAGE="https://developers.yubico.com/yubihsm-connector/"
+SRC_URI="
+ https://developers.yubico.com/${PN}/Releases/${P}.tar.gz
+ https://dev.gentoo.org/~zx2c4/distfiles/${P}-vendor.tar.xz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+RESTRICT="test"
+
+DEPEND=""
+RDEPEND="
+ virtual/libusb:1
+ virtual/udev
+ acct-user/yubihsm-connector
+ acct-group/yubihsm-connector
+"
+BDEPEND=""
+
+src_compile() {
+ ego generate
+ ego build ${GOFLAGS}
+}
+
+src_install() {
+ dobin yubihsm-connector
+ systemd_dounit deb/yubihsm-connector.service
+ udev_dorules deb/70-yubihsm-connector.rules
+ insinto /etc
+ doins deb/yubihsm-connector.yaml
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}