summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/yubihsm-shell')
-rw-r--r--app-crypt/yubihsm-shell/Manifest1
-rw-r--r--app-crypt/yubihsm-shell/files/yubihsm-shell-2.4.0-remove-hardcoded-compiler-opts.patch20
-rw-r--r--app-crypt/yubihsm-shell/metadata.xml11
-rw-r--r--app-crypt/yubihsm-shell/yubihsm-shell-2.4.0.ebuild29
4 files changed, 61 insertions, 0 deletions
diff --git a/app-crypt/yubihsm-shell/Manifest b/app-crypt/yubihsm-shell/Manifest
new file mode 100644
index 000000000000..06ca5892b1cc
--- /dev/null
+++ b/app-crypt/yubihsm-shell/Manifest
@@ -0,0 +1 @@
+DIST yubihsm-shell-2.4.0.tar.gz 334956 BLAKE2B 93a86baa1e463aa5200e31e9cc657642f37e05ec6e9897bb35f0b518df83b38c69e365766170d76aeeae6da357f3c2fce736c03665861c7ed4f2b56805a7eb3a SHA512 2b08e6e8932ff3bc12d1233d88147264a9875ce145290e29fb6b8f25eeb8e502afff9e7d02714a50454b85b0f01b09c0321d830a483d6b4f7afb962adce882d5
diff --git a/app-crypt/yubihsm-shell/files/yubihsm-shell-2.4.0-remove-hardcoded-compiler-opts.patch b/app-crypt/yubihsm-shell/files/yubihsm-shell-2.4.0-remove-hardcoded-compiler-opts.patch
new file mode 100644
index 000000000000..633e5e05422d
--- /dev/null
+++ b/app-crypt/yubihsm-shell/files/yubihsm-shell-2.4.0-remove-hardcoded-compiler-opts.patch
@@ -0,0 +1,20 @@
+diff -ru yubihsm-shell-2.4.0-orig/cmake/SecurityFlags.cmake yubihsm-shell-2.4.0/cmake/SecurityFlags.cmake
+--- yubihsm-shell-2.4.0-orig/cmake/SecurityFlags.cmake 2023-04-07 20:11:44.438751635 +0200
++++ yubihsm-shell-2.4.0/cmake/SecurityFlags.cmake 2023-04-07 20:12:30.588873600 +0200
+@@ -4,7 +4,7 @@
+ CMAKE_C_COMPILER_ID STREQUAL "AppleClang" OR
+ CMAKE_C_COMPILER_ID STREQUAL "GNU")
+
+- add_compile_options (-Wall -Wextra -Werror)
++ add_compile_options (-Wall -Wextra)
+ add_compile_options (-Wformat -Wformat-nonliteral -Wformat-security)
+ add_compile_options (-Wshadow)
+ add_compile_options (-Wcast-qual)
+@@ -13,7 +13,6 @@
+ add_compile_options (-pedantic -pedantic-errors)
+ add_compile_options (-fpie -fpic)
+ if (NOT FUZZ)
+- add_compile_options(-O2)
+ add_definitions (-D_FORTIFY_SOURCE=2)
+ endif ()
+
diff --git a/app-crypt/yubihsm-shell/metadata.xml b/app-crypt/yubihsm-shell/metadata.xml
new file mode 100644
index 000000000000..2914927d575f
--- /dev/null
+++ b/app-crypt/yubihsm-shell/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zx2c4@gentoo.org</email>
+ <name>Jason A. Donenfeld</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Yubico/yubihsm-shell</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-crypt/yubihsm-shell/yubihsm-shell-2.4.0.ebuild b/app-crypt/yubihsm-shell/yubihsm-shell-2.4.0.ebuild
new file mode 100644
index 000000000000..acc0bbc3eb7c
--- /dev/null
+++ b/app-crypt/yubihsm-shell/yubihsm-shell-2.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Components used to interact with the YubiHSM 2"
+HOMEPAGE="https://developers.yubico.com/yubihsm-shell/"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
+PATCHES=( "${FILESDIR}"/${P}-remove-hardcoded-compiler-opts.patch )
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test"
+
+DEPEND="
+ dev-libs/openssl:=
+ net-misc/curl
+ dev-libs/libedit
+ virtual/libusb:1
+ sys-apps/pcsc-lite
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-util/gengetopt
+ virtual/pkgconfig
+"