summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/yubikey-manager')
-rw-r--r--app-crypt/yubikey-manager/Manifest6
-rw-r--r--app-crypt/yubikey-manager/yubikey-manager-4.0.8.ebuild42
-rw-r--r--app-crypt/yubikey-manager/yubikey-manager-4.0.9.ebuild39
-rw-r--r--app-crypt/yubikey-manager/yubikey-manager-5.2.0.ebuild53
-rw-r--r--app-crypt/yubikey-manager/yubikey-manager-5.4.0-r1.ebuild53
-rw-r--r--app-crypt/yubikey-manager/yubikey-manager-5.4.0.ebuild53
6 files changed, 163 insertions, 83 deletions
diff --git a/app-crypt/yubikey-manager/Manifest b/app-crypt/yubikey-manager/Manifest
index ed88c94f3c4b..a001c6487902 100644
--- a/app-crypt/yubikey-manager/Manifest
+++ b/app-crypt/yubikey-manager/Manifest
@@ -1,2 +1,4 @@
-DIST yubikey-manager-4.0.8.tar.gz 147076 BLAKE2B efdefb15c3939bfb2171766aec195fb776668894d4439565840587d14387999e052aee6eb225b9332662f1ebdbf1db24fceb606393e23d591ff61b91c1ee96f5 SHA512 87352bbb133eead48d1588df2db5420687278a9f76ceb283a53af8eab3d29e30c86e01a588a6da2884e6dac6af192ad355a28745f2f8505ef6cd0e96dea3e9c7
-DIST yubikey-manager-4.0.9.tar.gz 145952 BLAKE2B e7a5488be1163e3f3f82c049b7c068c4be82debfccab1d6a60c1f9bdebcab4df94f257082e9c83d6bb0ea037bdab4b47b924d27890537d066205e2fbc28d2066 SHA512 bbffbdf9437d0f2de0b7713fe577a342c8da95e9d9512cb5118374b63637dbde6ee95e516dbb47bbea3af5b2e5edd495882c7e4adcbec1fd3eb750471a50add5
+DIST yubikey_manager-5.2.0.tar.gz 184873 BLAKE2B 09041c23e23ff01cad2d126face63006d1648dfe8d2e7a47b7113deed990143c83a36b6c60458dc9cbf55a71ddf286b8259c97ee982044dbc554231655fb82e2 SHA512 988c25f378e0ce5b53ba5a47aac5fd5a136653f1592af5e9c7440eef7336903cf459a567b4be02119262dba70c3058f5d9f26049dc21c1d934dcf8897eedc03d
+DIST yubikey_manager-5.2.0.tar.gz.sig 309 BLAKE2B bb1a012832c99aaa94404717560e72fb93352b82dd3c0091cb492cde65706c39b9e2411e38a36150d77e72f6397d98cef643d0b392c1751e9c109de3468c9a39 SHA512 926a7a7c40d38bcc0a48e3b44f3eb673c16f7bed73701f5cb6f9ac4418c9f2a242b8d2af9459093ec10e8c188410412a8ba8c05a0fd4774a738629a4b0f874d4
+DIST yubikey_manager-5.4.0.tar.gz 188859 BLAKE2B e83d74b0d512b7a1076bf6de0860c3a29259e337ccf508e81572e5802b1b1dced4c098ea21b4a3d63294b51a042780bf875536c30f65d46ce76b7a80c0bc1fce SHA512 c773895957d17ceac8e944958435071fbb3a80469016a22aa13785a5bc009406870366e5b65d3d2ddbd2ed1722f84b377a49101f4db67f0d3c04daee852301b3
+DIST yubikey_manager-5.4.0.tar.gz.sig 310 BLAKE2B 933a6638b754a8d3f23486f8adeb03e1b9c54d313370675f3e9e517751b495a5f3afae048b9740360459c86bef754618d9b8308cc30d8ae027421ee6f972fef1 SHA512 825d3e455b9cb9263a1336ac2d601fc2e25146ca45f143c16e559c5374c2aa0fc27f0330f5114e58186e02784e1ebda5e864726fea009dfb47377dcf5a3a32f4
diff --git a/app-crypt/yubikey-manager/yubikey-manager-4.0.8.ebuild b/app-crypt/yubikey-manager/yubikey-manager-4.0.8.ebuild
deleted file mode 100644
index 946c6bf3f775..000000000000
--- a/app-crypt/yubikey-manager/yubikey-manager-4.0.8.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_PEP517=poetry
-
-inherit distutils-r1
-
-DESCRIPTION="Python library and command line tool for configuring a YubiKey"
-HOMEPAGE="https://developers.yubico.com/yubikey-manager/"
-# Per https://github.com/Yubico/yubikey-manager/issues/217, Yubico is
-# the official source for tarballs, not Github
-SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv x86"
-IUSE="ssl"
-
-# app-crypt/ccid required for
-# - 'ykman oath'
-# - 'ykman openpgp'
-# - 'ykman piv'
-RDEPEND="
- app-crypt/ccid
- dev-python/click[${PYTHON_USEDEP}]
- <dev-python/cryptography-39[${PYTHON_USEDEP}]
- dev-python/fido2:0/0.9[${PYTHON_USEDEP}]
- dev-python/pyscard[${PYTHON_USEDEP}]
- ssl? ( >=dev-python/pyopenssl-0.15.1[${PYTHON_USEDEP}] )"
-BDEPEND="test? (
- dev-python/makefun[${PYTHON_USEDEP}]
-)"
-
-distutils_enable_tests pytest
-
-python_install_all() {
- distutils-r1_python_install_all
- doman man/ykman.1
-}
diff --git a/app-crypt/yubikey-manager/yubikey-manager-4.0.9.ebuild b/app-crypt/yubikey-manager/yubikey-manager-4.0.9.ebuild
deleted file mode 100644
index 71a5219bfd87..000000000000
--- a/app-crypt/yubikey-manager/yubikey-manager-4.0.9.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..11} )
-DISTUTILS_USE_PEP517=poetry
-
-inherit distutils-r1
-
-DESCRIPTION="Python library and command line tool for configuring a YubiKey"
-HOMEPAGE="https://developers.yubico.com/yubikey-manager/"
-SRC_URI="https://github.com/Yubico/yubikey-manager/releases/download/${PV}/${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
-IUSE="ssl"
-
-# app-crypt/ccid required for
-# - 'ykman oath'
-# - 'ykman openpgp'
-# - 'ykman piv'
-RDEPEND="
- app-crypt/ccid
- dev-python/click[${PYTHON_USEDEP}]
- <dev-python/cryptography-39[${PYTHON_USEDEP}]
- dev-python/fido2:0/1.0[${PYTHON_USEDEP}]
- dev-python/pyscard[${PYTHON_USEDEP}]
- ssl? ( >=dev-python/pyopenssl-0.15.1[${PYTHON_USEDEP}] )"
-BDEPEND="
- test? ( dev-python/makefun[${PYTHON_USEDEP}] )"
-
-distutils_enable_tests pytest
-
-python_install_all() {
- distutils-r1_python_install_all
- doman man/ykman.1
-}
diff --git a/app-crypt/yubikey-manager/yubikey-manager-5.2.0.ebuild b/app-crypt/yubikey-manager/yubikey-manager-5.2.0.ebuild
new file mode 100644
index 000000000000..278c8aa54fe4
--- /dev/null
+++ b/app-crypt/yubikey-manager/yubikey-manager-5.2.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=poetry
+
+inherit distutils-r1 verify-sig
+
+MY_PN="${PN/-/_}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python library and command line tool for configuring a YubiKey"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager/"
+# According to https://github.com/Yubico/yubikey-manager/issues/518 the release
+# tarballs on Yubico Web site and on GitHub should be identical, and at least
+# for recent releases the latter are signed as well. Only the automatically
+# generated "Source code (tar.gz)" tarballs should not be used.
+# Still, prefer the former if available.
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${MY_P}.tar.gz
+ verify-sig? ( https://developers.yubico.com/${PN}/Releases/${MY_P}.tar.gz.sig )"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv x86"
+IUSE="ssl"
+VERIFY_SIG_OPENPGP_KEY_PATH="/usr/share/openpgp-keys/yubico.com.asc"
+
+# app-crypt/ccid required for
+# - 'ykman oath'
+# - 'ykman openpgp'
+# - 'ykman piv'
+RDEPEND="
+ app-crypt/ccid
+ >=dev-python/click-8.0[${PYTHON_USEDEP}]
+ <dev-python/cryptography-44[${PYTHON_USEDEP}]
+ dev-python/fido2:0/1.0[${PYTHON_USEDEP}]
+ >=dev-python/keyring-23.4[${PYTHON_USEDEP}]
+ >=dev-python/pyscard-2.0[${PYTHON_USEDEP}]
+ ssl? ( >=dev-python/pyopenssl-0.15.1[${PYTHON_USEDEP}] )"
+BDEPEND="
+ test? ( dev-python/makefun[${PYTHON_USEDEP}] )
+ verify-sig? ( >=sec-keys/openpgp-keys-yubico-20220824 )"
+
+S="${WORKDIR}"/${MY_P}
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman man/ykman.1
+}
diff --git a/app-crypt/yubikey-manager/yubikey-manager-5.4.0-r1.ebuild b/app-crypt/yubikey-manager/yubikey-manager-5.4.0-r1.ebuild
new file mode 100644
index 000000000000..fc22190f735e
--- /dev/null
+++ b/app-crypt/yubikey-manager/yubikey-manager-5.4.0-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=poetry
+
+inherit distutils-r1 verify-sig
+
+MY_PN="${PN/-/_}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python library and command line tool for configuring a YubiKey"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager/"
+# According to https://github.com/Yubico/yubikey-manager/issues/518 the release
+# tarballs on Yubico Web site and on GitHub should be identical, and at least
+# for recent releases the latter are signed as well. Only the automatically
+# generated "Source code (tar.gz)" tarballs should not be used.
+# Still, prefer the former if available.
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${MY_P}.tar.gz
+ verify-sig? ( https://developers.yubico.com/${PN}/Releases/${MY_P}.tar.gz.sig )"
+
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="ssl"
+VERIFY_SIG_OPENPGP_KEY_PATH="/usr/share/openpgp-keys/yubico.com.asc"
+
+# app-crypt/ccid required for
+# - 'ykman oath'
+# - 'ykman openpgp'
+# - 'ykman piv'
+RDEPEND="
+ app-crypt/ccid
+ >=dev-python/click-8.0[${PYTHON_USEDEP}]
+ <dev-python/cryptography-45[${PYTHON_USEDEP}]
+ dev-python/fido2:0/1.0[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ >=dev-python/pyscard-2.0[${PYTHON_USEDEP}]
+ ssl? ( >=dev-python/pyopenssl-0.15.1[${PYTHON_USEDEP}] )"
+BDEPEND="
+ test? ( dev-python/makefun[${PYTHON_USEDEP}] )
+ verify-sig? ( >=sec-keys/openpgp-keys-yubico-20220824 )"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman man/ykman.1
+}
diff --git a/app-crypt/yubikey-manager/yubikey-manager-5.4.0.ebuild b/app-crypt/yubikey-manager/yubikey-manager-5.4.0.ebuild
new file mode 100644
index 000000000000..a3f8053a2c6a
--- /dev/null
+++ b/app-crypt/yubikey-manager/yubikey-manager-5.4.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=poetry
+
+inherit distutils-r1 verify-sig
+
+MY_PN="${PN/-/_}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python library and command line tool for configuring a YubiKey"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager/"
+# According to https://github.com/Yubico/yubikey-manager/issues/518 the release
+# tarballs on Yubico Web site and on GitHub should be identical, and at least
+# for recent releases the latter are signed as well. Only the automatically
+# generated "Source code (tar.gz)" tarballs should not be used.
+# Still, prefer the former if available.
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${MY_P}.tar.gz
+ verify-sig? ( https://developers.yubico.com/${PN}/Releases/${MY_P}.tar.gz.sig )"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="ssl"
+VERIFY_SIG_OPENPGP_KEY_PATH="/usr/share/openpgp-keys/yubico.com.asc"
+
+# app-crypt/ccid required for
+# - 'ykman oath'
+# - 'ykman openpgp'
+# - 'ykman piv'
+RDEPEND="
+ app-crypt/ccid
+ >=dev-python/click-8.0[${PYTHON_USEDEP}]
+ <dev-python/cryptography-45[${PYTHON_USEDEP}]
+ dev-python/fido2:0/1.0[${PYTHON_USEDEP}]
+ <dev-python/keyring-25[${PYTHON_USEDEP}]
+ >=dev-python/pyscard-2.0[${PYTHON_USEDEP}]
+ ssl? ( >=dev-python/pyopenssl-0.15.1[${PYTHON_USEDEP}] )"
+BDEPEND="
+ test? ( dev-python/makefun[${PYTHON_USEDEP}] )
+ verify-sig? ( >=sec-keys/openpgp-keys-yubico-20220824 )"
+
+S="${WORKDIR}"/${MY_P}
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman man/ykman.1
+}