summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/acme-sh/acme-sh-2.8.8.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/app-crypt/acme-sh/acme-sh-2.8.8.ebuild b/app-crypt/acme-sh/acme-sh-2.8.8.ebuild
deleted file mode 100644
index 3c699f79842c..000000000000
--- a/app-crypt/acme-sh/acme-sh-2.8.8.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_PN="${PN/-/.}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A pure Unix shell script implementing ACME client protocol"
-HOMEPAGE="https://github.com/acmesh-official/acme.sh"
-SRC_URI="https://github.com/acmesh-official/${MY_PN}/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
-
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-
-RDEPEND="
- net-misc/curl
- || ( dev-libs/libressl dev-libs/openssl:0 )
- || ( net-analyzer/netcat net-analyzer/openbsd-netcat )
- || ( net-misc/socat www-servers/apache:2 www-servers/nginx )
- virtual/cron
-"
-
-src_install() {
- einstalldocs
- newdoc dnsapi/README.md README-dnsapi.md
- newdoc deploy/README.md README-deploy.md
-
- keepdir /etc/acme-sh
- doenvd "${FILESDIR}"/99acme-sh
-
- insinto /etc/bash/bashrc.d
- doins "${FILESDIR}"/acme.sh
-
- exeinto /usr/share/acme.sh
- doexe acme.sh
-
- insinto /usr/share/acme.sh/dnsapi
- doins -r dnsapi/*.sh
-
- insinto /usr/share/acme.sh/deploy
- doins -r deploy/*.sh
-
- insinto /usr/share/acme.sh/notify
- doins -r notify/*.sh
-
- dosym ../share/acme.sh/acme.sh usr/bin/acme.sh
-}