summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/certbot-apache/certbot-apache-0.9.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-crypt/certbot-apache/certbot-apache-0.9.3.ebuild b/app-crypt/certbot-apache/certbot-apache-0.9.3.ebuild
new file mode 100644
index 000000000000..5714f37e9244
--- /dev/null
+++ b/app-crypt/certbot-apache/certbot-apache-0.9.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python2_7)
+
+EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+
+inherit git-r3 distutils-r1
+
+DESCRIPTION="Apache plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+RDEPEND="app-crypt/certbot[${PYTHON_USEDEP}]
+ app-crypt/acme[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/python-augeas[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${P}/certbot-apache
+
+python_test() {
+ nosetests || die
+}