summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/moolticute/moolticute-9999.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/app-crypt/moolticute/moolticute-9999.ebuild b/app-crypt/moolticute/moolticute-9999.ebuild
index 8609d2fec945..789f753ee725 100644
--- a/app-crypt/moolticute/moolticute-9999.ebuild
+++ b/app-crypt/moolticute/moolticute-9999.ebuild
@@ -34,6 +34,15 @@ DEPEND="${RDEPEND}"
S="${WORKDIR}/${P/_/-}"
+src_prepare() {
+ default
+
+ # Fill version.h with package version
+ if [[ ${PV} != 9999* ]]; then
+ sed -i "s/\"git\"/\"v${PV/_/-}\"/" src/version.h || die
+ fi
+}
+
src_configure() {
eqmake5 PREFIX="/usr" Moolticute.pro
}