summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/libmd/libmd-1.0.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-crypt/libmd/libmd-1.0.0-r1.ebuild b/app-crypt/libmd/libmd-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..61a43ba2c9ed
--- /dev/null
+++ b/app-crypt/libmd/libmd-1.0.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit multilib
+
+DESCRIPTION="Message Digest functions from BSD systems"
+HOMEPAGE="https://www.hadrons.org/software/libmd/"
+SRC_URI="https://archive.hadrons.org/software/libmd/${P}.tar.xz"
+
+LICENSE="|| ( BSD BSD-2 ISC BEER-WARE public-domain )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static-libs"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ if ! use static-libs; then
+ rm "${D}"/usr/$(get_libdir)/libmd.la || die
+ fi
+}