summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-dicts/dictd-wn/dictd-wn-2.0.ebuild')
-rw-r--r--app-dicts/dictd-wn/dictd-wn-2.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-dicts/dictd-wn/dictd-wn-2.0.ebuild b/app-dicts/dictd-wn/dictd-wn-2.0.ebuild
new file mode 100644
index 000000000000..1b56748ad4e0
--- /dev/null
+++ b/app-dicts/dictd-wn/dictd-wn-2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+MY_P=${P/td/t}
+DESCRIPTION="WordNet for dict"
+HOMEPAGE="http://www.dict.org/"
+SRC_URI="ftp://ftp.dict.org/pub/dict/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=app-text/dictd-1.5.5"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf || die "configure failed"
+ emake || die "compile failed"
+ emake db || die "compile database failed"
+}
+
+src_install() {
+ insinto /usr/lib/dict
+ doins wn.dict.dz wn.index || die
+}