summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-dicts/mecab-ipadic/mecab-ipadic-2.7.0.20070801-r1.ebuild')
-rw-r--r--app-dicts/mecab-ipadic/mecab-ipadic-2.7.0.20070801-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-dicts/mecab-ipadic/mecab-ipadic-2.7.0.20070801-r1.ebuild b/app-dicts/mecab-ipadic/mecab-ipadic-2.7.0.20070801-r1.ebuild
new file mode 100644
index 000000000000..f38e31ffc78e
--- /dev/null
+++ b/app-dicts/mecab-ipadic/mecab-ipadic-2.7.0.20070801-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="${PN}-${PV%.*}-${PV/*.}"
+
+DESCRIPTION="IPA dictionary for MeCab"
+HOMEPAGE="https://taku910.github.io/mecab/"
+SRC_URI="https://downloads.sourceforge.net/${PN%-*}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="ipadic"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
+IUSE="unicode"
+
+DEPEND="app-text/mecab[unicode=]"
+
+src_configure() {
+ econf $(use_with unicode charset UTF-8)
+}