summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-dicts/myspell-bg')
-rw-r--r--app-dicts/myspell-bg/Manifest1
-rw-r--r--app-dicts/myspell-bg/metadata.xml10
-rw-r--r--app-dicts/myspell-bg/myspell-bg-4.3.ebuild40
3 files changed, 51 insertions, 0 deletions
diff --git a/app-dicts/myspell-bg/Manifest b/app-dicts/myspell-bg/Manifest
new file mode 100644
index 000000000000..ea49844bf346
--- /dev/null
+++ b/app-dicts/myspell-bg/Manifest
@@ -0,0 +1 @@
+DIST OOo-full-pack-bg-4.3.zip 1360735 SHA256 47eb184d7b5af1365ce1124a07538632b39cb3f9c752fa5bda5955b668d11a9a SHA512 1c4acf0c8377c6ec3f0dd26c84a5232be88b1fecabcb08dfae4f45bf819c770427731cbf1b01d65d3a182cccc3d0bcaabf3ab85735221e2ff09fc47bd66341d7 WHIRLPOOL c90172bb472806b7cdc82ba044f5d9283a2b1da40051b3ac1fa832d861d351a52427e224c8f14c46089557c4f96568a2b0b4abdb96fcb0c3129223b117ca3c0b
diff --git a/app-dicts/myspell-bg/metadata.xml b/app-dicts/myspell-bg/metadata.xml
new file mode 100644
index 000000000000..54627db59f98
--- /dev/null
+++ b/app-dicts/myspell-bg/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">bgoffice</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-dicts/myspell-bg/myspell-bg-4.3.ebuild b/app-dicts/myspell-bg/myspell-bg-4.3.ebuild
new file mode 100644
index 000000000000..4875174a976c
--- /dev/null
+++ b/app-dicts/myspell-bg/myspell-bg-4.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+MY_P="OOo-full-pack-bg-${PV}"
+
+MYSPELL_DICT=(
+ "bg_BG.aff"
+ "bg_BG.dic"
+)
+
+MYSPELL_HYPH=(
+ "hyph_bg_BG.dic"
+)
+
+MYSPELL_THES=(
+ "th_bg_BG.dat"
+ "th_bg_BG.idx"
+)
+
+inherit myspell-r2
+
+DESCRIPTION="Bulgarian dictionaries for myspell/hunspell"
+HOMEPAGE="http://bgoffice.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bgoffice/${MY_P}.zip"
+
+LICENSE="GPL-2 LGPL-2.1 MPL-1.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # remove licenses that are suffixed with txt
+ # so they are not picked by install dodoc
+ rm -rf *.txt
+}