summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/audacity/audacity-3.3.3.ebuild')
-rw-r--r--app-doc/audacity/audacity-3.3.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-doc/audacity/audacity-3.3.3.ebuild b/app-doc/audacity/audacity-3.3.3.ebuild
new file mode 100644
index 000000000000..c033739b6a0e
--- /dev/null
+++ b/app-doc/audacity/audacity-3.3.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="HTML reference manual for Audacity"
+HOMEPAGE="https://www.audacityteam.org/"
+
+if [[ ${PV} = 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/audacity/audacity-manual.git"
+else
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/help"
+ SRC_URI="amd64? ( https://github.com/audacity/audacity-manual/releases/download/v${PV}/audacity-manual-${PV}.tar.gz )"
+fi
+
+LICENSE="CC-BY-3.0"
+SLOT="0"
+
+src_install() {
+ docinto html
+ dodoc -r "${S}"/manual/{m,man}
+ dodoc "${S}"/manual/{favicon.ico,index.html,quick_help.html}
+ dosym ../../doc/${PF}/html /usr/share/${PN}/help/manual
+}