summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/cantera-docs/cantera-docs-2.6.0.ebuild')
-rw-r--r--app-doc/cantera-docs/cantera-docs-2.6.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-doc/cantera-docs/cantera-docs-2.6.0.ebuild b/app-doc/cantera-docs/cantera-docs-2.6.0.ebuild
new file mode 100644
index 000000000000..60d16f9141e4
--- /dev/null
+++ b/app-doc/cantera-docs/cantera-docs-2.6.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg
+
+DESCRIPTION="Documentation API reference for Cantera package libraries"
+HOMEPAGE="https://cantera.org"
+SRC_URI="https://github.com/band-a-prend/gentoo-overlay/releases/download/ct-docs-${PV}/${P}_modified_menu.tar.xz -> ${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~riscv ~x86"
+
+S="${WORKDIR}/"
+
+src_install() {
+ insinto /usr/share/cantera/doc/
+ doins -r "${S}/."
+
+ make_desktop_entry "/usr/bin/xdg-open /usr/share/cantera/doc/doxygen/html/index.html" "Cantera Doxygen Documentation" "text-html" "Development"
+ make_desktop_entry "/usr/bin/xdg-open /usr/share/cantera/doc/sphinx/html/index.html" "Cantera Sphinx Documentation" "text-html" "Development"
+}