summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/doxygen/files/doxygen-1.8.16-link_with_pthread.patch')
-rw-r--r--app-doc/doxygen/files/doxygen-1.8.16-link_with_pthread.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/app-doc/doxygen/files/doxygen-1.8.16-link_with_pthread.patch b/app-doc/doxygen/files/doxygen-1.8.16-link_with_pthread.patch
new file mode 100644
index 000000000000..c3c49e6b5e7c
--- /dev/null
+++ b/app-doc/doxygen/files/doxygen-1.8.16-link_with_pthread.patch
@@ -0,0 +1,16 @@
+diff --git a/addon/doxywizard/CMakeLists.txt b/addon/doxywizard/CMakeLists.txt
+index 6ae71a6..e03ea7c 100644
+--- a/addon/doxywizard/CMakeLists.txt
++++ b/addon/doxywizard/CMakeLists.txt
+@@ -104,9 +104,9 @@ doxywizard.rc
+ )
+
+ if(Qt5Core_FOUND)
+- target_link_libraries(doxywizard Qt5::Core Qt5::Gui Qt5::Widgets Qt5::Xml doxygen_version)
++ target_link_libraries(doxywizard Qt5::Core Qt5::Gui Qt5::Widgets Qt5::Xml doxygen_version pthread)
+ else()
+- target_link_libraries(doxywizard ${QT_LIBRARIES} ${QT_QTMAIN_LIBRARY} doxygen_version)
++ target_link_libraries(doxywizard ${QT_LIBRARIES} ${QT_QTMAIN_LIBRARY} doxygen_version pthread)
+ endif()
+
+ install(TARGETS doxywizard DESTINATION bin)