summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/doxygen/files')
-rw-r--r--app-doc/doxygen/files/doxygen-1.8.16-link_with_pthread.patch16
-rw-r--r--app-doc/doxygen/files/doxygen-1.8.17-ensure_static_support_libraries.patch27
-rw-r--r--app-doc/doxygen/files/doxygen-1.8.9.1-empty-line-sigsegv.patch20
-rw-r--r--app-doc/doxygen/files/doxygen-1.9.1-do_not_force_libcxx.patch13
-rw-r--r--app-doc/doxygen/files/doxygen-1.9.1-header-dep.patch25
-rw-r--r--app-doc/doxygen/files/doxygen-1.9.1-ignore-bad-encoding.patch23
-rw-r--r--app-doc/doxygen/files/doxygen-1.9.2-xml-static.patch29
-rw-r--r--app-doc/doxygen/files/doxygen-1.9.4-gcc12-include.patch19
-rw-r--r--app-doc/doxygen/files/doxygen-1.9.4-link_with_pthread.patch24
9 files changed, 0 insertions, 196 deletions
diff --git a/app-doc/doxygen/files/doxygen-1.8.16-link_with_pthread.patch b/app-doc/doxygen/files/doxygen-1.8.16-link_with_pthread.patch
deleted file mode 100644
index c3c49e6b5e7c..000000000000
--- a/app-doc/doxygen/files/doxygen-1.8.16-link_with_pthread.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --git a/addon/doxywizard/CMakeLists.txt b/addon/doxywizard/CMakeLists.txt
-index 6ae71a6..e03ea7c 100644
---- a/addon/doxywizard/CMakeLists.txt
-+++ b/addon/doxywizard/CMakeLists.txt
-@@ -104,9 +104,9 @@ doxywizard.rc
- )
-
- if(Qt5Core_FOUND)
-- target_link_libraries(doxywizard Qt5::Core Qt5::Gui Qt5::Widgets Qt5::Xml doxygen_version)
-+ target_link_libraries(doxywizard Qt5::Core Qt5::Gui Qt5::Widgets Qt5::Xml doxygen_version pthread)
- else()
-- target_link_libraries(doxywizard ${QT_LIBRARIES} ${QT_QTMAIN_LIBRARY} doxygen_version)
-+ target_link_libraries(doxywizard ${QT_LIBRARIES} ${QT_QTMAIN_LIBRARY} doxygen_version pthread)
- endif()
-
- install(TARGETS doxywizard DESTINATION bin)
diff --git a/app-doc/doxygen/files/doxygen-1.8.17-ensure_static_support_libraries.patch b/app-doc/doxygen/files/doxygen-1.8.17-ensure_static_support_libraries.patch
deleted file mode 100644
index 285ea16ac96e..000000000000
--- a/app-doc/doxygen/files/doxygen-1.8.17-ensure_static_support_libraries.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From d7b0a0ef152312b9242cbbe7405ee49310e7909e Mon Sep 17 00:00:00 2001
-From: Matthias Maier <tamiko@43-1.org>
-Date: Sun, 1 Mar 2020 11:50:14 -0600
-Subject: [PATCH] CMake: Mark the libmsc library static
-
-With CMake 3.16.4 at least we end up with a shared library and
-subsequent linking fails.
----
- libmscgen/CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/libmscgen/CMakeLists.txt b/libmscgen/CMakeLists.txt
-index 079fcfc..fbf3f4f 100644
---- a/libmscgen/CMakeLists.txt
-+++ b/libmscgen/CMakeLists.txt
-@@ -16,7 +16,7 @@ foreach(lex_file ${LEX_FILES})
- FLEX_TARGET(${lex_file} ${lex_file}.l ${GENERATED_SRC}/${lex_file}.cpp COMPILE_FLAGS "${LEX_FLAGS}")
- endforeach()
-
--add_library(mscgen
-+add_library(mscgen STATIC
- gd.c
- gd_security.c
- gdfontt.c
---
-2.24.1
-
diff --git a/app-doc/doxygen/files/doxygen-1.8.9.1-empty-line-sigsegv.patch b/app-doc/doxygen/files/doxygen-1.8.9.1-empty-line-sigsegv.patch
deleted file mode 100644
index cfa56174c5eb..000000000000
--- a/app-doc/doxygen/files/doxygen-1.8.9.1-empty-line-sigsegv.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-removeEmptyLines() segfaults on empty string
-
-https://bugs.gentoo.org/show_bug.cgi?id=454348
-http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=676423
-
-Patch written by Thibaut Paumard <paumard@users.sourceforge.net>
---- a/src/htmlgen.cpp
-+++ b/src/htmlgen.cpp
-@@ -1022,6 +1022,11 @@
- static QCString removeEmptyLines(const QCString &s)
- {
- BufStr out(s.length()+1);
-+ if (s.length()==0)
-+ {
-+ out.addChar('\0');
-+ return out.data();
-+ }
- const char *p=s.data();
- if (p)
- {
diff --git a/app-doc/doxygen/files/doxygen-1.9.1-do_not_force_libcxx.patch b/app-doc/doxygen/files/doxygen-1.9.1-do_not_force_libcxx.patch
deleted file mode 100644
index f33f619e62ed..000000000000
--- a/app-doc/doxygen/files/doxygen-1.9.1-do_not_force_libcxx.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 3775ed1..b3a1af6 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -23,7 +23,7 @@ option(build_doc "Build user manual (HTML and PDF)" OFF)
- option(build_doc_chm "Build user manual (CHM)" OFF)
- option(use_sqlite3 "Add support for sqlite3 output [experimental]." OFF)
- if (CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
-- option(use_libc++ "Use libc++ as C++ standard library." ON)
-+ option(use_libc++ "Use libc++ as C++ standard library." OFF)
- endif()
- option(use_libclang "Add support for libclang parsing." OFF)
- option(static_libclang "Link to a statically compiled version of LLVM/libclang." OFF)
diff --git a/app-doc/doxygen/files/doxygen-1.9.1-header-dep.patch b/app-doc/doxygen/files/doxygen-1.9.1-header-dep.patch
deleted file mode 100644
index 66e647cf53b5..000000000000
--- a/app-doc/doxygen/files/doxygen-1.9.1-header-dep.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 6ea1b4104fe2524c9c1f2cdd5f7de8c1a48f3f87 Mon Sep 17 00:00:00 2001
-From: James Le Cuirot <chewi@gentoo.org>
-Date: Tue, 14 Sep 2021 20:56:20 +0100
-Subject: [PATCH] Fix missing dependency on configvalues.h
-
-It's referenced by config.h, which is referenced by most things.
-
-This was failing to build for me with Ninja on the m68k Linux platform. I don't know why it works elsewhere, could just be luck.
-
----
- src/CMakeLists.txt | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index 18406488dd..0e0c5f78de 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -215,6 +215,7 @@ add_library(doxymain STATIC
- ${GENERATED_SRC}/ce_parse.cpp
- # custom generated files
- ${GENERATED_SRC}/lang_cfg.h
-+ ${GENERATED_SRC}/configvalues.h
- ${GENERATED_SRC}/ce_parse.h
- ${GENERATED_SRC}/resources.cpp
- #
diff --git a/app-doc/doxygen/files/doxygen-1.9.1-ignore-bad-encoding.patch b/app-doc/doxygen/files/doxygen-1.9.1-ignore-bad-encoding.patch
deleted file mode 100644
index 5dd7578f24ec..000000000000
--- a/app-doc/doxygen/files/doxygen-1.9.1-ignore-bad-encoding.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Hack to avoid "UnicodeDecodeError: 'utf-8' codec can't decode byte 0xb0 in position 45: invalid start byte"
-in src/._xmlgen.cpp which is binary. This doesn't seem like it should be present at the time the docs
-are generated, but this is simpler for now.
---- a/doc/translator.py
-+++ b/doc/translator.py
-@@ -1454,10 +1454,13 @@ class TrManager:
-
- # Read content of the file as one string.
- assert os.path.isfile(fname)
-- f = xopen(fname)
-- cont = f.read()
-- cont = ''.join(cont.split('\n')) # otherwise the 'match' function won't work.
-- f.close()
-+ try:
-+ with xopen(fname) as f:
-+ cont = f.read()
-+ cont = ''.join(cont.split('\n')) # otherwise the 'match' function won't work.
-+ except UnicodeDecodeError:
-+ print("Skipping {0} because of decoding errors".format(fname))
-+ return
-
- # Remove the items for identifiers that were found in the file.
- while lst_in:
diff --git a/app-doc/doxygen/files/doxygen-1.9.2-xml-static.patch b/app-doc/doxygen/files/doxygen-1.9.2-xml-static.patch
deleted file mode 100644
index a106d6eb5a93..000000000000
--- a/app-doc/doxygen/files/doxygen-1.9.2-xml-static.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-https://github.com/doxygen/doxygen/pull/8862
-https://github.com/doxygen/doxygen/issues/8855
-
-[sam: deleted msc hunk b/c we had it in a patch of our
-own.]
-
-From 5c3a4ad2773fc911b341b36b00528603afbe1602 Mon Sep 17 00:00:00 2001
-From: albert-github <albert.tests@gmail.com>
-Date: Wed, 27 Oct 2021 16:41:28 +0200
-Subject: [PATCH] issue #8855 Unable to build 1.9.2
-
-All other libraries have been declared STATIC so better to declare the cmls and mscgen libraries also STATIC.
----
- libxml/CMakeLists.txt | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/libxml/CMakeLists.txt b/libxml/CMakeLists.txt
-index 96c56534f9..596ed90887 100644
---- a/libxml/CMakeLists.txt
-+++ b/libxml/CMakeLists.txt
-@@ -11,7 +11,7 @@ set_source_files_properties(${GENERATED_SRC}/xml.l.h PROPERTIES GENERATED 1)
-
- FLEX_TARGET(xml xml.l ${GENERATED_SRC}/xml.cpp COMPILE_FLAGS "${LEX_FLAGS}")
-
--add_library(xml
-+add_library(xml STATIC
- ${GENERATED_SRC}/xml.cpp
- ${GENERATED_SRC}/xml.l.h
- )
diff --git a/app-doc/doxygen/files/doxygen-1.9.4-gcc12-include.patch b/app-doc/doxygen/files/doxygen-1.9.4-gcc12-include.patch
deleted file mode 100644
index 44505e4bed40..000000000000
--- a/app-doc/doxygen/files/doxygen-1.9.4-gcc12-include.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-https://github.com/doxygen/doxygen/commit/5198966c8d5fec89116d025c74934ac03ea511fa
-https://bugs.gentoo.org/844229
-
-From: Dimitri van Heesch <doxygen@gmail.com>
-Date: Fri, 6 May 2022 09:55:16 +0200
-Subject: [PATCH] issue #9312: Build: cache.h:53:14: error: 'exchange' is not a
- member of 'std'
-
---- a/src/cache.h
-+++ b/src/cache.h
-@@ -19,6 +19,7 @@
- #include <list>
- #include <unordered_map>
- #include <mutex>
-+#include <utility>
- #include <ctype.h>
-
- /*! Fixed size cache for value type V using keys of type K.
-
diff --git a/app-doc/doxygen/files/doxygen-1.9.4-link_with_pthread.patch b/app-doc/doxygen/files/doxygen-1.9.4-link_with_pthread.patch
deleted file mode 100644
index 66093eb7deb9..000000000000
--- a/app-doc/doxygen/files/doxygen-1.9.4-link_with_pthread.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff --git a/addon/doxywizard/.CMakeLists.txt.swp b/addon/doxywizard/.CMakeLists.txt.swp
-deleted file mode 100644
-index fc379d2..0000000
-Binary files a/addon/doxywizard/.CMakeLists.txt.swp and /dev/null differ
-diff --git a/addon/doxywizard/CMakeLists.txt b/addon/doxywizard/CMakeLists.txt
-index bb0e0eb..b6135bd 100644
---- a/addon/doxywizard/CMakeLists.txt
-+++ b/addon/doxywizard/CMakeLists.txt
-@@ -132,12 +132,12 @@ apply_editbin(doxywizard windows)
- endif()
-
- if(Qt5Core_FOUND)
-- target_link_libraries(doxywizard Qt5::Core Qt5::Gui Qt5::Widgets Qt5::Xml doxygen_version)
-+ target_link_libraries(doxywizard Qt5::Core Qt5::Gui Qt5::Widgets Qt5::Xml doxygen_version pthread)
- else()
- if(Qt6Core_FOUND)
-- target_link_libraries(doxywizard Qt6::Core Qt6::Gui Qt6::Widgets Qt6::Xml doxygen_version)
-+ target_link_libraries(doxywizard Qt6::Core Qt6::Gui Qt6::Widgets Qt6::Xml doxygen_version pthread)
- else()
-- target_link_libraries(doxywizard ${QT_LIBRARIES} ${QT_QTMAIN_LIBRARY} doxygen_version)
-+ target_link_libraries(doxywizard ${QT_LIBRARIES} ${QT_QTMAIN_LIBRARY} doxygen_version pthread)
- endif()
- endif()
-