summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/doxygen/files')
-rw-r--r--app-doc/doxygen/files/doxygen-1.8.15-link_with_pthread.patch32
-rw-r--r--app-doc/doxygen/files/doxygen-1.8.15-llvm7.patch11
2 files changed, 43 insertions, 0 deletions
diff --git a/app-doc/doxygen/files/doxygen-1.8.15-link_with_pthread.patch b/app-doc/doxygen/files/doxygen-1.8.15-link_with_pthread.patch
new file mode 100644
index 000000000000..54c0a96e5e1a
--- /dev/null
+++ b/app-doc/doxygen/files/doxygen-1.8.15-link_with_pthread.patch
@@ -0,0 +1,32 @@
+--- a/addon/doxysearch/CMakeLists.txt 2019-04-03 18:43:47.995610511 +0200
++++ b/addon/doxysearch/CMakeLists.txt 2019-04-03 18:45:27.730609191 +0200
+@@ -18,6 +18,7 @@
+ ${ZLIB_LIBRARIES}
+ ${WIN_EXTRA_LIBS}
+ qtools
++ pthread
+ )
+
+ add_executable(doxysearch.cgi
+@@ -27,6 +28,7 @@
+ ${XAPIAN_LIBRARIES}
+ ${ZLIB_LIBRARIES}
+ ${WIN_EXTRA_LIBS}
++ pthread
+ )
+
+ install(TARGETS doxyindexer doxysearch.cgi DESTINATION bin)
+--- a/addon/doxywizard/CMakeLists.txt 2019-04-03 18:43:59.139610364 +0200
++++ b/addon/doxywizard/CMakeLists.txt 2019-04-03 18:45:14.151609371 +0200
+@@ -102,9 +102,9 @@
+ )
+
+ if(Qt5Core_FOUND)
+- target_link_libraries(doxywizard Qt5::Core Qt5::Gui Qt5::Widgets Qt5::Xml)
++ target_link_libraries(doxywizard Qt5::Core Qt5::Gui Qt5::Widgets Qt5::Xml pthread)
+ else()
+- target_link_libraries(doxywizard ${QT_LIBRARIES} ${QT_QTMAIN_LIBRARY})
++ target_link_libraries(doxywizard ${QT_LIBRARIES} ${QT_QTMAIN_LIBRARY} pthread)
+ endif()
+
+ install(TARGETS doxywizard DESTINATION bin)
diff --git a/app-doc/doxygen/files/doxygen-1.8.15-llvm7.patch b/app-doc/doxygen/files/doxygen-1.8.15-llvm7.patch
new file mode 100644
index 000000000000..861c79a6b0d9
--- /dev/null
+++ b/app-doc/doxygen/files/doxygen-1.8.15-llvm7.patch
@@ -0,0 +1,11 @@
+--- a/src/CMakeLists.txt 2019-04-04 06:51:41.509647160 +0200
++++ b/src/CMakeLists.txt 2019-04-04 06:52:08.413646804 +0200
+@@ -263,7 +263,7 @@
+ add_definitions(${LLVM_DEFINITIONS})
+ llvm_map_components_to_libnames(llvm_libs support core option)
+ target_compile_definitions(doxygen PRIVATE ${LLVM_DEFINITIONS})
+- set(CLANG_LIBS libclang clangTooling ${llvm_libs})
++ set(CLANG_LIBS libclang clangTooling clangBasic clangLex ${llvm_libs})
+ endif()
+
+ target_link_libraries(doxygen